Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion

osTicket v1.10 (stable) and Maintenance Release v1.9.15 are now available! Go get it now

Blank Page after Initial Install Screen

Hi All

I ahve tried to install the latest version of osticket on a Debian Etch server. After the initial setup page where the system asks for Admin user details and mysql database details, when i click on Install button, all i get is a blank page. I did not see any error messages in apache log. Also, the installation did not create any tables in the database.

Any help would be much appreciated!

Thanks
«1

Comments

  • Same problem

    I've just tryed to install it into a apache server, php5 and mysql and after the configuration only appears a blank page...
  • Help anyone

    Help anyone?
  • Blank screen after initial configuration information

    I have the same issue. Anyone have any solutions???

    Thanks
  • open up /main.inc.php and look at line 42

    CHANGE
        ini_set('display_errors',0);
    ini_set('display_startup_errors',0);


    TO
        ini_set('display_errors',1);
    ini_set('display_startup_errors',1);


    Then let us know which errors you are getting to help narrow it down.
  • jpowers40828;4877 said:
    open up /main.inc.php and look at line 42

    CHANGE
        ini_set('display_errors',0);
    ini_set('display_startup_errors',0);


    TO
        ini_set('display_errors',1);
    ini_set('display_startup_errors',1);


    Then let us know which errors you are getting to help narrow it down.
    Alas, I have tried this and I got no errors....square one :(
  • What page is it trying to load? /osticket/?
  • Its trying to load the "/osticket/setup/index.php" page.
  • In the index.php file ` line 159 right after the close brackets, but still in the php section add echo $inc;

    That will let us know which file is failing it out.
  • jpowers40828;4887 said:
    In the index.php file ` line 159 right after the close brackets, but still in the php section add echo $inc;

    That will let us know which file is failing it out.
    Okay, in setup/index.php line number 159 just before the end of the PHP section i inserted "echo $inc;" (without quotes) and when I go to the "osticket/setup/" URL I get "install.inc.php".

    This is on the page where it asks for the information for the setup such as "Title", "dbname"...etc
  • in ostconfig.php ~ line 33,34,35,36 are the values set, or still
    %CONFIG-DB?

    And make sure that in setup/setup.inc.php ~ line 22 looks like

    ini_set('display_startup_errors',1);
    ini_set('display_errors',1); //We want the user to see errors during install process.
  • jpowers40828;4900 said:
    in ostconfig.php ~ line 33,34,35,36 are the values set, or still
    %CONFIG-DB?
    Yup, everything looks like "%CONFIG-DB"
    And make sure that in setup/setup.inc.php ~ line 22 looks like

    ini_set('display_startup_errors',1);
    ini_set('display_errors',1); //We want the user to see errors during install process.
    Yes, these lines look good as well.
  • I have the exact same problem so i am following this thread...Do you think it could be a permissions issue?
  • I'm not sure. Something is failing out, so that the page doesn't display anything, but then there are no php errors... I'm running out of ideas with zero errors showing up, but let's try this.

    in setup/index.php ~ line 191 change it from require to include.

    If that still comes up as a blank page, try changing index.php so it will make an error, just to make sure that errors are really showing up. add an extra semicolon or parenthesis somewhere.
  • I changed require to include and still got the blank page. I then changed index.php and got an error:

    Parse error: syntax error, unexpected ',' in S:\Tickets\setup\index.php on line 159
  • Could it be something that i skipped while setting up IIS settings? When i click on the 'install' button what file does it try to access? how do i verify my permissions,etc?
  • Same Problem

    Hi, I have the same problem. New install, PHP 5.2.6, MySQL 5.0.67. Blank screen, have tried to add code suggested to display errors and nothing shows up.

    Please can you suggest something else.
  • setup/index.php ~ line 91 CHANGE

    if(!$errors && !($fp = @fopen(CONFIGFILE,'r+'))){

    TO

    if(!$errors && !($fp = fopen(CONFIGFILE,'r+'))){


    ~ line 153 CHANGE

    @fclose($fp);

    TO

    fclose($fp);


    The @ suppresses warnings, lets see if one of them is erroring out. Then I would say you should start commenting out sections in order to find out where its failing.
  • The other thing I noticed while looking through setup/index.php ~ line 137 is the syntax of the sql query

    CHANGE

                        $sql='INSERT INTO '.PREFIX.'ticket SET created=NOW(),ticketID='.db_input($tid).
    \",priority_id=2,dept_id=1,email='support@osticket.com',name='osTicket Support' \".
    \",subject='osTicket Installed!',status='open',source='Web'\";



    TO

                        $sql='INSERT INTO '.PREFIX.'ticket (created, ticketID, priority_id, dept_id, email, name, subject, status, source) VALUES (NOW(),'.db_input($tid).\",2,1,'support@osticket.com','osTicket Support','osTicket Installed!','open','Web')\";


    I think SET is for when you UPDATE.
  • On line 122 of setup/index.php CHANGE

                        $sql='INSERT INTO '.PREFIX.'staff SET created=NOW(), isadmin=1,change_passwd=0,group_id=1,dept_id=1 '.
    ',email='.db_input($_POST['email']).',lastname='.db_input('Admin').
    ',username='.db_input($_POST['username']).',passwd='.db_input(MD5($_POST['password'])).
    ',timezone_offset='.db_input($tzoffset);


    TO

                        $sql='INSERT INTO '.PREFIX.'staff (created, isadmin, change_passwd, group_id, dept_id, email, lastname, username, passwd, timezone_offset) VALUES (NOW(), 1,0,1,1,'.db_input($_POST['email']).','.db_input('Admin').','.db_input($_POST['username']).','.db_input(MD5($_POST['password'])).','.db_input($tzoffset).')';
  • I just made all the suggested changes and still nothing. I will try to debug it line by line and see where the problems is.
  • I noticed another sql problem in osticket.sql.

    I've attached the changed file.
    osticket.zip
    4K
  • I'm having the same issue?

    I'm having the same issue? I have done all the steps posted and get the black screen after setup....
  • Had the same problem as the rest of you... couldn't seem to figure out why I would get a blank screen after clicking submit on the installation page.

    I am installing 1.6 r4 on a CentOS 5.2 server.

    Finally realized I didn't have php-mysql installed.

    yum install php-mysql

    It worked after that.

    Cheers!!
  • I have tried all of the above, except the downloading the revised zip file because I wasn't registered. I still get a blank page after trying to install.

    the values of ostconfig.php don't seem to change. I've set permission to everyon with full control. I am using apache 2.2, php5 and mysql4.1.
    I've started fresh again in the hopes that there was something I missed.

    if anyone can help I would appreciate it
  • correction

    I just tried the osticket.sql file and still no go
  • PHP add on?

    Hi,

    I was having the same issue too, and realised that the MySQL add-ins were not loaded in PHP (i'm using Windows).

    Re-Ran the PHP installer, choosing the CHANGE option. Added MySQL in the EXTENSIONS section. It then proceeded to add in the required new files and the install finished.

    Next, added the extension=php_mysql.dll to the php.ini file, and rebooted the machine.

    Now when I run the setup, it goes to the next screen - yay!

    Hope this helps - always the basic things...
  • perfect! thanks plinkykev! Reran php install and choose change then added mysql extension and reset Microsoft IIS. I checked my php.ini but already had the extension entry at the bottom of the file.
  • nevermind - figured it out - needed php-mysql installed.

    Thanks anyways everyone.
  • Confirmed again. Had the same blank screen after the install page. Installing the mysql extension for php fixed the issue.

    For those running ubuntu like me, the package is installed with:

    sudo apt-get install php5-mysql
  • change
    max_execution_time=30

    to
    max_execution_time=180

    in php.ini file and restart all services

    should work.
Sign In or Register to comment.