Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion

osTicket v1.10 (stable) and Maintenance Release v1.9.15 are now available! Go get it now

IMAP Email issue

Hi there,

I have built my php with IMAP

Configure Command './configure' '--enable-mbstring' '--enable-imap'

My PHP functions correctly and this information above is also given in my phpinfo. However when I select to use pop3 email account in the email account settings I get this error.

IMAP doesn't exist. PHP must be compiled with IMAP enabled.

Does anyone know of a way to solve this issue? Other than this everything appears to be working fine.

Thanks

Comments

  • I am not exactly sure, but try adding '--with-imap=shared' '--with-imap-ssl' as well.
  • 4ice;1210 said:
    I am not exactly sure, but try adding '--with-imap=shared' '--with-imap-ssl' as well.
    nope still the same issue with these options for php :(

    '--with-imap=shared' '--with-imap-ssl'
  • I have just upgraded to RC3, I can confirm that this issue is still present.
  • cmo,

    This is not an issue with osTicket. Use phpinfo() to confirm that imap extensions is supported in your PHP installation.

    If need be, please check with your webhost or webmaster.
  • peter;1256 said:
    cmo,

    This is not an issue with osTicket. Use phpinfo() to confirm that imap extensions is supported in your PHP installation.

    If need be, please check with your webhost or webmaster.
    Hi Peter,

    I am running this locally on an apache/suse/php5 box. Here is my php compile line

    ./configure' '--with-imap=shared' '--with-imap-ssl' -- taken from my phpinfo

    I tried with both --with-imap and --with-imap=shared as suggested by someone else.
  • I have solved it with this configuration line. It seems it does need the ssl but the =shared is not a valid option as specified above. I recompiled and it now fetches the email.

    ./configure' '--with-imap' '--with-imap-ssl'

    ./configure' '--with-imap=shared' '--with-imap-ssl'
  • Same issue on remote host

    I've passed phpinfo in my web hosting and I've obtained this results:

    '--with-imap=shared' '--with-imap-ssl'

    Can I remove the '=shared' remotely? Is it necesary to remove it? Do I have to ask my hosting provider to recompile PHP with '--with-imap' instead of '--with-imap=shared'? Isn't there any easier way?

    Thank you very much.

    Regards.
  • why not try easyphp

    why not download easyphp.........php, mysql and apache installed with this package.

    goto its folder and search for PHP.INI.......edit php.ini file located in Conf Folder.. search for dlls and remove ; from start of line of imap ....now your problem will be fixed
  • solution

    change

    ;extension=php_imap.dll

    to this

    extension=php_imap.dll

    remove ; from start of line....your problem will be fixed
  • Problem it's in my hosting

    As it's installed remotelly in my web hosting, I cannot access to PHP configuration files as php.ini . As you can see in my first post, IMAP is activated with "shared" option. ¿Is there any solution in osTicket config so it can use the "shared" option?

    Thank you very much.
Sign In or Register to comment.