Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion

osTicket v1.10 (stable) and Maintenance Release v1.9.15 are now available! Go get it now

Email piping not updating ticket threads

Hi everyone
I'm working on my first time configuring osTicket. (great system!) I have email piping setup, I'm not receiving any errors, I get notice of new tickets, etc. just fine. However, it was my understanding that via email piping that should a client reply via email to a ticket, that email piping would update the thread for their ticket on the web; I'm not getting any updates to ticket threads when a reply is sent via email.

Obviously I'm missing something. Not getting any errors, but not getting updated threads either.

I'm hosted on HostGator, have my mail forwarding setup to the path to pipe.php, and email piping enable in the settings. What step am I missing or am I misunderstanding what email piping will do?

Thanks in advance for your help.

Comments

  • Thought I'd best put my path to pipe.php, just in case that was the issue:
    "|/usr/bin/php -q /home/USERNAME/public_html/DOMAINFOLDER/osTICKETFOLDER/api/pipe.php"
    *Obviously I changed the user and folder names to reflect those actual names when setting up the forward. ;)
  • First of all, check to ensure that the outbound email address is set correctly, so that the customer is sending responses to the right reply-to address.
  • Hi Kelli
    Yes, the correct email address is set for the outbound. Any idea what else could be the issue?
  • Are the replies turning up as new tickets? It is strange that the system is sending emails out letting you know of the reply, but not putting them into the system...
  • Okay - upon further checking & testing; I'm finding that only clients are receiving emails, not me as Admin. So as Admin I'm NOT receiving email notification of new tickets, nor of replies to tickets; but clients ARE receiving email notifications when they submit a new ticket and when tickets are replied to.

    However, when clients attempt to reply to a ticket via email (not by going to the web interface & replying), that email reply is not updating the ticket, and no - it's not creating a new ticket. I have no clue where it's going.

    I have the email address used for piping also setup to download mail to my mail client. This AM, I've tried to set a different email as the default Alert email for staff & admins, with every other mail setting going to the pipe email setup. Still no notifications to me as Admin.

    Clearly I have a setting wrong somewhere, just puzzled as to what. Any help is appreciated. :)
  • Please have a look at the error log on your Dashboard and if possible also check the log of your web server. You might want to increase the logging level as suggest on http://osticket.com/wiki/Installation

    Besides, you need to check that the settings are correct (those on the Settings screen and those of the Departments -- click on the Dept. Name to get to the details).
  • Email piping replies to existing tickets creating new tickets
    PRedmond;12390 said:
    Are the replies turning up as new tickets? It is strange that the system is sending emails out letting you know of the reply, but not putting them into the system...
    See that this thread is a few months old, but this is the problem that I'm having, and not sure how to sort out. Any email replies to tickets are successfully being piped into osTicket, but creating new tickets (not updating the existing ticket) :confused:

    I'd like to know how to configure email replies to tickets to pick up the ticket number (for example [#15]) from the subject line and populate into the ticket.

    SOLUTION:
    I realise now that this was occurring because I had a forwarder for the email address that the ticket was being sent to.

    This meant that any replies to my osTicket admin email address didn't recognize the email address that I was attempting to send a reply from.
    http://osticket.com/forums/showthread.php?t=4459
  • re:Email piping not updating ticket threads

    It is quite strange that the system is sending emails out letting you know of the reply, but not putting them into the system.
  • mmm yummy zombie thread.
    Just going to kill that now.
    If you have an issue Kate Smith, please open your own thread.
    Thanks.
This discussion has been closed.