Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion

osTicket v1.10 (stable) and Maintenance Release v1.9.15 are now available! Go get it now

Can't get POP3 fetch to work

Hey guys,

donno why, it just doesn't fetch the mails.
Could you tell me correct cronjob command ?

Regards
Isa

Comments

  • Did you enabled it in Admin panel? Make sure it is enabled under 'Email Settings' and auto cron is checked under 'General Settings'.
  • Yes. It is ;(
    Both enabled.

    that's why i'm askin'

    BTW : logindata is correct (testetd 3 times)

    running /api/cron.php manually gives me
    root@server1:/# php5-cgi /home/www/web1/html/ticketsupport/api/cron.php
    X-Powered-By: PHP/5.2.0-8+etch5~pu1
    Set-Cookie: PHPSESSID=7b4da6c21d80f9fcf7e9f22a8f6e2fdc; path=/
    Expires: Thu, 19 Nov 1981 08:52:00 GMT
    Cache-Control: no-store, no-cache, must-revalidate, post-check=0, pre-check=0
    Pragma: no-cache
    Content-type: text/html

    root@server1:/#
    and i get alerts via email :
    Unknown remote host [78.51.66.98]

    image
    image
    image
  • It shouldn't be checking the host IP when invoked locally. Will look into it.

    Alternatively you can spawn cron also by visiting yourdomain.com/osticket_dir/scp/cron.php when logged in as staff/admin. This file is suppose to be requested on page load as 1X1 clear image when auto cron is enabled.
  • DONE
    Systemadmingave me wrong pop3 mailbox name.
    i was checking inbox of info@ not of support@
    so my testmails could not arrive ;)

    BUT : using the 1x1 pixel image cron still doesn't run
  • I have a similar problem, i've got email checking enabled, pop3 settings are correct, staff cron turned on.

    crontab is: */5 * * * * nobody /usr/bin/php /path/to/public_html/support/api/cron.php

    where path/to/ is the actual path of course.
  • changed nobody to admin because nobody is not enabled. try calling via commandline:
    ssh said:

    [root@linux css]# su admin
    [admin@linux css]$ /usr/bin/php /home/admin/domains/intelligentflight.com.au/public_html/support/api/cron.php
    [admin@linux css]$
    Test email not in queue
  • Unknown Remote Host

    I keep getting the following error: Unknown remote host [ipaddresshere]

    I'm using 1and1 and their pop email server is always their domain: pop.1and1.com

    Could this be the problem? If so, does anyone know how I can fix it.

    Currently, osTicket is not fetching the pop e-mails.

    When I run the cron script from a browser...I get 77 on the page.

    I'm on a Linux server
  • I updated my api setting to include the ip address and key. I also double checked my cron job entry and there was a difference in the way my new host handles php scripts.

    Everything is working fine now.

    I also made sure that I enabled cron in "Settings" and also enabled pop settings within each individual email account.

    This is my cronjob entry:
    MAILTO=spaycegirl@XXXXXXX
    */5 * * * * /usr/local/bin/php /pathto/osticket/api/cron.php

    This is the result being emailed to me:
    X-Powered-By: PHP/4.4.7
    Set-Cookie: PHPSESSID=ac9559a7dcebac3f7418a1c990855de2; path=/
    Expires: Thu, 19 Nov 1981 08:52:00 GMT
    Cache-Control: no-store, no-cache, must-revalidate, post-check=0, pre-check=0
    Pragma: no-cache
    Content-type: text/html

    I enabled MAILTO just so I could see what was going on. I'm deleting after I finish testing.

    Best Regards!
  • iam using window server,any advice?
  • Looks like I'm having a similar issue. I've set up the cron.php to run every 10 minutes and it seems to be logging into my mailserver(pop3) and retrieving tickets that way. My problem is, it's not sending confirmation emails(autoresponders) or even error logs from osticket. I've checked the settings inside of osTicket... Added the mailserver ip to the API settings...

    I do have some errors when the cron.php is run locally:
    PHP Notice: Undefined index: REMOTE_ADDR in D:\Inetpub\wwwroot\support\main.in
    c.php on line 97
    PHP Notice: Undefined variable: dblink in D:\Inetpub\wwwroot\support\include\my
    sql.php on line 25
    PHP Notice: Undefined variable: dblink in D:\Inetpub\wwwroot\support\include\my
    sql.php on line 28
    Does anyone know what the issue could be?

    When I run the cron script from the browser I get 77 as well... Not sure where to go from here and I'm tired. :)
  • DackR,

    If the cron works and tickets are created then the issue has nothing to do with cron job. For auto response to work it needs to be enabled in multiple places.

    *Make sure auto response is enabled in Setting -> Preference
    *Make sure the email setting associated with the pop account doesn't disable auto response.
    *Make sure the department the email maps to has auto responder enabled.

    Yes, it sucks but it is needed to make the system flexible and robust.
  • Auto Responder is enabled on New Ticket and New Messages.
    Alerts and notices are all enabled.
    One of my departments had auto responders disabled. I've changed that.

    Also checked my settings on the outgoing mail server settings and I've disabled any restrictions so that anonymous emails can be sent out correctly.... I'm still not getting anything sent from osTicket. No errors, no nothing. (I can send emails to my pop3 accounts and the emails are imported into osTicket, however.)

    I can send and receive emails through the same email server (my own) through Outlook and Thunderbird.

    It seems that at one point, error reports were being generated but not sent out... I have about 6 emails in the dropped email folder that have "%ADMIN-EMAIL" as the FROM and TO lines and the Subject says "Fatal DB Error" and message body "Unable to connect to the DB" These all appear to be from the day I setup osTicket initially though... but it shows that it almost worked at one point :p

    I'm using Windows Server 2003, so if anyone has suggestions, I'd love to hear them.
  • What happens when you reply to an existing ticket? The user gets the response?
    If not then you are having issues with PHP sending out emails. osTicket uses default mailer for outgoing email ( this will change soon) and it might be worth checking php.ini mail settings.
  • I checked my php.ini settings.
    Under the [mail] heading:

    SMTP: localhost
    smtp_port: 25

    ;sendmail_from: [email]myuser@mydomain.com[/email] //This line was commented out, I uncommented it

    It appears to be working now... how strange that the issue was caused by sendmail_from... I checked it twice before noticing it was commented out.

    Thanks Peter!
  • how u update the api settins and how u get the key?
  • Uriel, you update the API settings by logging on to your admin section and clicking Settings tab. There are three links at the top. One is API. Click on API to define your key and enter the IP address.
  • Here also problems with the POP3

    I have used pop3 (checking every 1 minute) buth the osticket system doesn't open the mailbox. When i add a ticket and I reply on it i geth a reply.

    Why is the osticket not opening the mailbox?

    (sorry for the bad english)
  • where can i find the php.ini ?
    I have searched for it whitout succes
Sign In or Register to comment.