Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion

osTicket v1.10 (stable) and Maintenance Release v1.9.15 are now available! Go get it now

Where do I setup smtp details for osticket to use to send alerts

I am having problems whereby the alerts are bouncing. I believe this is related to qmail and plesk. The solution appears to be to supply the smtp details, unfortunately I cannot see ehere I can set these. All I see is POP3 for the receive mail setup.

Any help would be appreciated.



  • Access email settings by going to your osTicket admin panel (go to the directory you installed osTicket in /scp/admin.php). Then click the email tab (third tab over), click on the email address you would like to configure, then under SMTP settings, enter your outgoing email server settings (your hosting provider can give these to you if you don't know them). Make sure you Status is set to Enable under SMTP settings. Once osTicket has verified these server settings, it should say they were successful.

    Hope this helps,
  • Thanks Wyatt,

    Unfortunately there is no section for SMTP settings - just POP3:

    POP3 Setting (Optional)
    Please be patient, the system will try to login to mail server to validate the entered login info.
    POP3 Status Enable Disable
    POP3 Host
    POP3 User
    POP3 Password
    Fetch Frequency Delay intervals in minutes
    Delete Messages Delete fetched message(s)

    Any ideas why the SMTP settings are not being shown?

  • I'm no programing expert, nor am I too familiar with osTicket myself, but I would start by making sure all of the files/directories uploaded correctly, and that your database is configured correctly, and that osTicket has the correct permissions to everything. Make sure osTicket doesn't report any errors at the top of the screen when you access the admin panel. If none of this works, I would recommend deleting everything (including the mySQL database) and reinstall.

  • Thanks Wyatt - it all seemed to install OK and everything works.

    I do not see how the email gets back to the customer with no problem whatsoever, but the notification email to the "support person" is bounced.

    Both use qmail - very odd indeed!
  • I have reinstalled and there is still no smtp capability.

    In the database I can see the table for pop3, but there is no table for smtp...

    Can anybody else help please?
  • I'm really sorry for the delay in response, but hopefully this will help.

    Again, I'm not an expert, so proceed at your own risk (BACKUP!) Try editing the file smtp.php which is located in /include/pear/Mail/ Here you should find where you can specify SMTP server settings.

  • I am having the same issue. Incredible that it has been so difficult to find an answer especially since there seem to be so many having the same issue. There is no "SMTP Settings (optional)" found under email settings, or anywhere in Osticket. I figured that there should be at least a file somewhere then to manually force the SMTP configuration but have not been able to find it yet.

    Per the last remarks in this post, I have checked for a file named smtp.php which the post stated would be found located in (under OSticket install) /include/pear/Mail/ . Unfortunately, there is no such file in this directory.

    Has anyone got a workable answer on this?
  • There have been quite a few issues with the ostickets but this one about the alerts bouncing is a new one that I am reading for the first time!! It is a good thing that we are getting ready answers for little things though the larger problem remains just as it is!! I hope we are able to find a permanent way out here or else, it may become a real headache!! Please keep us updated on how things are on this issue!!I am planning to set it to my new ac repair austin service site, hope it works well without any flaws.
  • Presuming that you are running 1.6 ST you get to these settings via:

    1. Login as an Admin.
    2. Click on Admin Panel -> Click on Emails tab -> click on the email address
    3. scroll down to SMTP Settings (Optional).
    set Status to Enable.
    set SMTP Host: your.mailserver.ext
    SMTP Port: 25
    Authentication Required: No
    4. click Submit.

    Note server setting may very from this (you may use SMTP-Auth). If you are running 1.6 ST and do not see this page, then you should check and make sure there are no errors being logged. The file that displays this admin config page is

  • i have problem when create new ticket the id of ticket not send to my e-mail
  • @fawaz please start your own thread.

    Closing thread since this is from 2011.
This discussion has been closed.