Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion

osTicket v1.10 (stable) and Maintenance Release v1.9.15 are now available! Go get it now

Cannot add new staff member

When i try to add another staff member i have some issues, detailed below.

This is able to be replicated every time. Steps to replicate below.

Opera 9.24 on Windows XP
* Request for authentication, i login
* head back to Staff
* Click add new User
* Rinse and repeat

On IE 6, Windows XP (just in case it was an opera issue)
* Blank Screen
* Refresh page, get request for authentication
* Authenticate.. rinse and repeat.

I tried this with both a 30 minute admin session setting, and 0 minute to be sure it wasnt something with cookies.

Tested with Opera 9.24 on three of the office computers.

Comments

  • I am already looking into the issue.
  • Attempting to edit a staff member does the same thing btw :)
  • And so does clicking on user groups and add group
  • Ah hah! it's not actually the adding of a staff member. Login, go to Admin Panel, go to Staff, Go to any other page.

    The staff list is breaking it ;)
  • The issue occurs when globals are enabled causing conflicts with the session. A temp fix is to disable register globals (It is a good idea anyways :))
  • along this same line, if you click on staff and then department it logs you out everytime as well. Turning off register_globals fixes it.

    I cant remember why i turned them on in the first place since im pretty sure php
    comes with them turned off by default.
  • Going into staff or view ticket resets the $staff variable to null, which causes the $_SESSION['staff'] to get killed ;)

    My register globals got turned on because i recompiled php and it decided to use a different location for php.ini other than /etc/ where my usual config is :)
  • peter;65 said:
    The issue occurs when globals are enabled causing conflicts with the session. A temp fix is to disable register globals (It is a good idea anyways :))
    I can't turn Register Globals off, I'm not the admin of the computer. Any way to modify the code to prevent this?

    Thanks,
    Eddie
  • Fixed

    I had similar issue, I succeeded fixing it by uploading a .htaccess file to the ost directory as following:

    In order to turn this setting off, create a file named ".htaccess" in the directory you want this setting to affect. If you want it to affect an entire domain name, create the ".htaccess" file in the root directory for that domain (usually, this directory is named after the domain). Within the file, place the following line:

    php_flag register_globals off


    ENJOY ost
  • Same for me

    I have the same issue. Cant add staff, modify users in groups, or anything that deals with the staff and user groups admin. I cant modify .htaccess on my server so that work around wont correct my issues.
  • No alteration required

    You need not alter the file. No such file exist in the ost upload folder. You can create a .txt file in note pad with the text php_flag register_globals off in windows explorer change the htaccess.txt file to .htaccess and upload it to the ost main directory, that's it.

    Alternatively you can used attached file to rename it as .htaccess and simply upload it to the mail folder in which all the ost files / folders are uploaded.
    htaccess.txt
    29B
  • scientica;152 said:
    I had similar issue, I succeeded fixing it by uploading a .htaccess file to the ost directory as following:

    In order to turn this setting off, create a file named ".htaccess" in the directory you want this setting to affect. If you want it to affect an entire domain name, create the ".htaccess" file in the root directory for that domain (usually, this directory is named after the domain). Within the file, place the following line:

    php_flag register_globals off


    ENJOY ost
    This did not work on my host. After adding a.htaccess file to the subdirectory, the script in the subdirectory would no longer load.

    Your suggestion got me pointed in the right direction, though. It turns out that PhpSuExec is installed on my host. I followed the instructions here----> https://www.power360hosting.com/support/index.php?_m=knowledgebase&_a=viewarticle&kbarticleid=16

    Now it works fine! The downside is that the the fix may effect the entire website.

    Thanks!
  • Solution wont work

    on my host i do not have access right to change the .htaccess file. i can protect the directory thru their control panel only. i cant upload .htaccess files to my host server either. i need a fix and deals directly with the script as a whole.
    scientica;154 said:
    You need not alter the file. No such file exist in the ost upload folder. You can create a .txt file in note pad with the text php_flag register_globals off in windows explorer change the htaccess.txt file to .htaccess and upload it to the ost main directory, that's it.

    Alternatively you can used attached file to rename it as .htaccess and simply upload it to the mail folder in which all the ost files / folders are uploaded.
  • The problem just is not not going away.

    Hi everyone,
    I tried the .htaccess solution presented by Peter. followed all the posts and links to all other suggestions, Followed the solution suggested by EddieCranford to power360host using php.ini and .htaccess combo, but could not get the desired result.
    My problem is happening only at the staff area of the admin panel. Everything else works just fine. At the staff area I get into a loop of clicking anything and logging in over again.

    My staff got this tool for Christmas, but they can not log in until now.
    If anyone can help us get this working b4 new year's eve, will be just great!!!
    the link to it is http://suporte.artmedia.net
    Thank you all for helping as all, all the time.

    Best regards,

    accosta
  • You Got it!!!!!!!!

    Thank you Peter.
    A wonderful new year!!!!!!!!!
  • peter;287 said:
    Hi Peter,

    register globals is off, but I still get a white screen when I press "Admin Panel" (both in IE7 and in FF). I wanted to try the above solution, but it appears that you have already changed it in the latest download.

    Any ideas?

    Thanks!!
  • Authentication Required

    change all file to:

    _SESSION['_staff']

    still have an issue Authentication Required
  • @Uriel: Have you tried using the fix by Eddie Cranford? My host does not nave .htaccess enabled so all new directives I have to create php.ini files as detailed previously.

    Also with Firefox I had to empty out all "Private Data" [CTRL+SHIFT+DEL] since the system was populating my ticket entries with tickets I had deleted and my logins kept failing. Once I did that my system was back to normal.
  • 4ice;408 said:
    Hi Peter,

    register globals is off, but I still get a white screen when I press "Admin Panel" (both in IE7 and in FF). I wanted to try the above solution, but it appears that you have already changed it in the latest download.

    Any ideas?

    Thanks!!
    When I turned on error reporting, I got errors with including PEAR. I now solved it, see http://www.osticket.com/forums/showthread.php?p=446#post446
Sign In or Register to comment.