Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion

osTicket v1.10 (stable) and Maintenance Release v1.9.15 are now available! Go get it now

osTicket reading global php.ini and not VS one

Hi,

basically simple question: any idea how to make osTicket read VS php.ini instead of global?

I'm using Virtualmin and i have php.ini set up for each Virtual Server, but osTicket ignores that and reads only global ini in /etc

My config: Virtualmin + PHP version 5.3.6 + Apache version 2.2.3 short_open_tag On (in VS php.ini, not in global) Server API: CGI/FastCGI... AND my phpinfo() tells me that: Loaded Configuration File IS /home/myserver/etc/php5/php.ini

Still osTicket ignores it, any idea how to fix this without enabling short_open_tag in global php.ini?

- Yorkki

Comments

  • i'd guess you are using a different php.ini. You can find that out very easily via the phpinfo() function in any php file.

    A second solution would be to enable short_open_tag via a .htaccess file with the following line

    php_flag short_open_tag = On



    Best
    T.
  • Hi, as i wrote above: my phpinfo() tells me that: Loaded Configuration File IS /home/myserver/etc/php5/php.ini

    so the site is using correct one, but osTicket, for some reason is still using global.. weird. Anyway, i will use .htaccess for atleast temp solution. Would be nice to find out where the problem is though.

    Thanks,

    - Yorkki

    p.s. the correct usage is: 'php_flag short_open_tag on'
  • oh, didn't read that you used phpinfo already :)

    I'm not too familiar with VirtualMin, but can't you set the respective option in the VirtualHosts declaration as well? Something like

    <VirtualHost ......>

    php_admin_flag short_open_tag = on

    </VirtualHost>


    Best
    T.
  • The only way I can think of to change this is to specifically turn it on via .htaccess for that site.
  • Yes, that is possible also. But the problem is not that i cant get this site up and running, the question is why osTicket still reads global ini instead of the site's own. Is it hardwired somewhere in the code or what? The .htaccess doesnt work btw, i start to get mails as soon as i turn it off in global php.ini:

    And the mail says: Short open tag disabled! - osTicket requires it turned ON.

    that mail comes every time my cron runs, and ofcourse, it doesnt read .htaccess

    i'll try httpd.conf now, doubt it'll work either, becouse of the cron...

    - Yorkki
  • Well, now i've tested em all, .htaccess, httpd.conf and php.ini and the only one that stops the "Short open tag disabled! - osTicket requires it turned ON." -email running in is when i set the tag in php.ini, and that is the global php.ini in /etc .. which sucks.

    - Yorkki
  • Ok, to sum it up, it was my bad i got these error messages. The thing was, that i was using cron job (set in crontab as the site user) and did NOT have specified the ini file it should use, eg. "php -c /home/mysite/etc/php5/php.ini /home/mysite/osticket/api/cron.php" , so ofcouse it used the /etc/php.ini, as a regular command-line php command would. DUH! Thanks Peter for pointing that out.

    - Yorkki
  • deleted spam reply. Closing thread to prevent further zombie-ing.
This discussion has been closed.