Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion

osTicket v1.10 (stable) and Maintenance Release v1.9.15 are now available! Go get it now

Cant upgrade because of mysql

hello there

i want to upgrade osticket from 1.6 to 1.8 but i cant because system says

Prerequisites:

These items are necessary in order to run the latest version of osTicket.
  • PHP v5.3 or greater - (5.4.22)
  • MySQL v5.0 or greater - (module loaded)

But checking version of my mysql i saw: Currently installed: 5.1.70

So, how can i upgrade osticket to 1.8 ?



Tagged:

Comments

  • edited December 2013
    Wow I miss read that...

    I would try upgrading your MySQL.  Chances are the installer isn't stating the right version of MySQL.
    You should also check your error logs to see if there are any errors being thrown.
  • edited December 2013
    I'm having the same issue.  I have verified through the server that we are running MySQL version 5.5.34-cll

    What could be causing this issue and, hence, not being about to finalize the upgrade process?

    Also checked the error logs and no errors are appearing, and we were upgrading from version 1.7 as well.


  • The db_version function is different for mysql/mysqli.. by one thing: 1.8 declares         $matches = array(); before setting it.. that's it. Unless its comparing to a different value, it is exactly the same.

    Checked, it uses builtin php version_compare function to check that mysql is >= 5.0.. should be pretty straightforward.

    Are you getting any errors in the logs etc?

    If not, you could probably bypass this (if you KNOW its greater than 5.0), by simply returning true from:

    /include/class.setup.php line 97:

      function check_mysql_version() {
            return true;// (version_compare(db_version(), $this->getMySQLVersion())>=0);
        }

Sign In or Register to comment.