Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion

osTicket v1.10 (stable) and Maintenance Release v1.9.15 are now available! Go get it now

IMAP doesn't exist. PHP must be compiled with IMAP enabled.

Hello!

I'm trying to get the system to fetch from some POP3 boxes yet each time I save the details I get the error above.

I have read a number of posts on this forum regarding the issue "IMAP doesn't exist. PHP must be compiled with IMAP enabled." but it doesn't seem to help me much as I couldn't find any where they confirmed IMAP was installed but not recognised. Also some of the promising discussions were closed off by the mods (not entirely sure why!).

I'm running Amazon EC2, LAMP stack on Ubuntu 13.00 with the latest stable PHP and MySQL distributions. I have already used
apt-get install php5-imap
To install IMAP, and this can be confirmed phpinfo() where you will see:

IMAPRex Logan, Mark Musone, Brian Wang, Kaj-Michael Lang, Antoni Pamies Olive, Rasmus Lerdorf, Andrew Skalski, Chuck Hagenbuch, Daniel R Kalowsky


So does anyone have any good ideas where to go next? Could I have IMAP installed but not turned on for instance?
Tagged:

Comments

  • I would try this site, and make sure that you restart apache after everything.


  • First off this is not an osTicket problem.  This is an apache/php problem. If you ran "apt-get install php5-imap" then you installed and enabled imap. You need to make sure that you restart Apache afterwards. The install script enables php5's imap when you ran it.

    To be honest there are so many places where this could reside (based on flavor) in Linux that I couldn't begin to tell you where it might be in your installation.  Here are just a couple locations:

    /etc/php5/apache2/conf.d/imap.ini
    /etc/php5/php.ini
    /etc/php.ini
    /etc/apache2/
    /etc/php/php.ini


    The short of it is some where your install script places something similar to:

    ; configuration for php IMAP module
    extension=imap.so


    in the extensions section of your php.ini or an included config file some where on your machine.
  • edited February 2014
    While this isn't an osTicket problem, it *is* a problem with Apache2/php5-fpm on Ubuntu 13.10.

    The .ini isn't linked from php's config for Apache. It's in /etc/php5/conf.d, and it needs to be in /etc/php5/apache2/conf.d.

    This command will resolve the issue:

    ln /etc/php5/conf.d/imap.ini /etc/php5/apache2/conf.d/20-imap.ini

    Reload php5-fpm and apache, and you should be good to go:

    service php5-fpm reload
    service apache2 reload
  • 3 steps:

    "sudo apt-get install php5-imap"

    "sudo php5enmod imap"

    "sudo /etc/init.d/apache2 restart"

    test in ubuntu server 14.04 - osTicket v1.9.4-RC1

This discussion has been closed.