Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion

osTicket v1.10 (stable) and Maintenance Release v1.9.15 are now available! Go get it now

Upgrade Error

The last two upgraded I get this error when I run 
/scp/upgrade.php

any suggestions?
Parse error
: syntax error, unexpected T_FUNCTION in /home/supportticketsthemezzcom/support.themezz.com/include/class.ticket.php on line 1916

Comments

  • Please help us to help you reading and following the posting guidelines in this thread: Please read before requesting assistance.

    My first guess however would be to ask what version of PHP your running.  osTicket 1.8.x requires PHP 5.3+.
  • To be more specific

    I was running 1.72 successfully in    domainname.com

    I saved ost-config.php locally

    I renamed domainname.com to domainname.com-OLD

    I uploaded 1.8.0.2  

    I placed ost-config.php back on the server in  domainname.com/include

    I loaded domainname.com/scp/upgrade.php    and get above error

    I run domainname.com/scp and get above error

    Any suggestions?

    thank you



  • And your PHP version?
  • Running 5.2 
    I will upgrade

    THANKS
  • Upgraded to PHP 5.4 and .... 

    ALL WORKS WELL !!!!!!!!!

    ****THANK YOU SO MUCH***********

  • You're very welcome.  I'm going to close this thread since your resolved.  Feel free to post again should you encounter any further difficulties.
This discussion has been closed.