Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion

osTicket v1.10 (stable) and Maintenance Release v1.9.15 are now available! Go get it now

How to Setup Mail Function

Hi!

I have successfully installed OSTicket Version 1.8.0.2 on a Ubuntu Server, I am already on the process of configuring the Email Settings and options, and on a separate machine, we are currently using Microsoft Exchange Server User for our mails, and these accounts are also the ones that are used on our MS Outlook.

How can I configure the email settings of OSticket so that our email accounts from our Server will be the ones to be used/connected to the OS Ticket? I am stuck in this step, please help me. :(

Thank you all! 
Tagged:

Comments

  • Depending on the version of Exchange you will need to tell Exhcange that its okay for your webserver to connect to your mail server. If memory serves me correctly that is located in Exchange Management Console -> Server Configuration -> Hub Transport -> Receive Connectors.

    Then it should just be the matter of going into osTicket and going to Admin panel -> Emails and configuring an email.


  • edited February 2014





  • May be I can contribute to this, having faced the same issue for many days but I fixed it somehow:

    In Admin Panel -> Emails -> click on the main email you will be using as a system email (example: techsupport@yourdomain.com)

    Then once the page opens, enter the username and password for this email account which you will use to authenticate in outlook too. Now, the tricky part which took me some time to figure out, as we too are using exchange server:

    Mail Account settings: Host name -> I put as IP address of my web server (try and find this correct IP address). I use port 143

    SMTP settings: SMTP Host --> I found out this from here:
    Open your outlook account settings from outlook itself by File -> Info ->Account settings -> Account settings again -> click on the email which is setup currently and click on 'Change' , then click on -> More settings --> then click on Connection tab --> click on 'Exchange proxy settings' at the bottom -> here you go, in connection settings you see a URL (example: webmail.yourdomain.com) or may be different. So I used this as SMTP host. SMTP Port is generally 25. Authentication required: Yes

    Click Save. Go to Diagnostic and try sending a mail, see if you receive any email.

    try this and see if it works.

  • Thank you for your response ntozier!

    Upon checking your suggestion the Receive Connectors is already enabled. 
    I've setup a clean Debian server, added osTicket and configured that. No problem so far.
    But since all my users are on MS network, I need to have the osTicket talk to Exchange 2007. 
    Or have it forwarded to the Exchange server. So what should I look at to accomplish this? Can you help me with the email configuratio part in a way that emails will be forwarded to our Exchange Server? Kindly see attached screenshots  for the setup that I am doing.

    Thank you for your help. :) 

    pic1.JPG
    952 x 406 - 108K
    pic2.JPG
    874 x 602 - 150K
  • edited February 2014
    Hi Nakul21!

    Thank you for your post. 

    Upon trying the steps that you have suggested. I got an error message on the Mail Account Settings, kindly see attached image (please see attached pic3) for the error and when I tried to add the SSL authentication type different error appeared( please see attched pic4).

    Please take note that it will only be used internally wherein emails from OS Ticket emails will go trough our Exchange server then finally to our Outlook account. Thanks!


    Again, thank you for your great help!!
    pic3.JPG
    866 x 640 - 194K
    pic4.JPG
    865 x 709 - 200K
  • the port 143 is for no-ssl. try it with port 993 (imap) or 995 (pop3)
  • Here's an over view of the settings that we use here (also using Exchange 2007)

    On your second screen shot you will need to go to fill out the Login information section and Mail Account section and SMTP Settings.

    i.e. fill out username and password for the account that you've created on your Exchange 2007 server for ticket emails.

    Then go down to the next section and select enable.
    enter the host (name of or ip of your Exhcange Server) [note: we use the short netbios name here]
    enter your port (143).
    Protocol (IMAP)
    Encryption (None)
    select Delete Fetched Emails.

    Under SMTP
    select enable.
    end SMTP host (name of or ip of your Exhcange Server) [note: we use the short netbios name here]
    SMTP Port (25)
    Authentication requires? set to no. [unless you require SMTP auth... but since you setup a transport you shouldn't need to]

    In your follow up post in your second screen shot you turned SSL on but didn't change the port #.  pm_3010's post indicated this already but I was trying to be thorough.
Sign In or Register to comment.