Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion

osTicket v1.10 (stable) and Maintenance Release v1.9.15 are now available! Go get it now

After Upgrade, attachments are missing from the posts

I've upgraded my system to 1.6 RC5 to 1.8.1 latest stable release. Also everything seemed green and all the attachments have migrated to the database. Also on the Database Table: xxxx_ticket_attachment all the attachments are showing.
However if I open a old ticket and which had attachments, I cannot see any attachments links. But if I attach some new file. It's showing and can doenload without hassle.
Do any body know to fix this.
Tagged:

Comments

  • Did you upgrade to 1.6ST first and then to 1.8.1? (a lot of people who have not have reported issues in the past)
    Are there any errors in your PHP error log?
    Are there any errors in the Admin panel -> Dashboard -> System Logs?

    Did you perform a site backup before you upgraded?  (You may want to restore your site and database to the old version and try upgrading again).  The attachments moved into the data base in 1.7, and the ability to move them back out was added back in via plugin in 1.8.1 it's possible that the later broke the upgrade process from 1.6.  You might try upgrading from 1.6 to 1.8.0.2 (or .3).

    Please help us to help you by reading and following the posting guidelines located in this thread: Please read before requesting assistance.  The more information you give us the better we will be able to assist you.

  • Hi ntozier,

    Thanks for the post,

    My platform details:

    osTicket v1.8.0.2
    Shard hosting
    Apache version 2.2.xx
    PHP version 5.3.xx
    MySQL version 5.5.xx
    Architecture x86_64
    Operating system linux



    Answer for your questions:

    I used the upgrade wizard which appeared after the file overwrite, as on upgrader manual. So I barely noticed, it showed me its upgrading to 1.6ST and some 1.7xx and so on. Is that correct? or do I need to mannually upgrade to 1.6ST?
    Also when importing attachments, I saw it shows as more than 100. Also when on last 10 or 20 attachments the upgrader failed and aborted. But again when  ran the upgrade wizard, all the things got completed and able to log in to the system and I noticed the mentioned 'attachment missing' issue for some tickets.

    on the system I can see these kind of many lines

    Upgrader - dd0022fb (task pending).
    Upgrader - dd0022fb (task pending).

    Yes I have the backup files and DB from old version and I've deleted the existing and re-upgraded 3 times and I'm ending in same situation.

    Thanks for the posting tips and I've modelled this post to be standard on the forum.


  • edited February 2014
    I was more saying that if you grabbed the 1.7.x archive and upgraded to that.  Then grabbed the 1.8.1 archive and upgraded to that (separate step) that you might have better luck with the attachments.  Generally the only time I have heard about people missing some attachments is if there was a problem reading the files.  You might want to check the file permissions on them.

    Are the file attachments still in the file system?  You might be able to install the storage-fs plugin and get them back that way.  https://github.com/osTicket/core-plugins ; I haven't tried that to see if it works after the fact.. and it probably wont work the way I want it to for you. :)

    Out of curiosity, how important are old attachments to you?  I'll ask the devs to take a look at this thread.
  • Oh... and there is this post that appears to be the same issue that you are having and he says that he thinks going from 1.6 to 1.7.5 and then to 1.8.1 worked for them.

    http://www.osticket.com/forum/discussion/76410/upgrade-1-6-st-to-1-8-1#latest
This discussion has been closed.