Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion

osTicket v1.10 (stable) and Maintenance Release v1.9.15 are now available! Go get it now

Problem with Email and SMTP settings for 1.8.1. What is the right settgings?

We've been using OsTicket 1.8.1 and Gmail Apps as email provider and having problems with notifications to both client and staff.
What should be the settings for:

SYSTEMS -> EMAILS -> Default outgoing email: "None - Use PHP mail" or our default email?
EMAILS -> EMAILS -> Select System Email --> Mail Account
EMAILS -> EMAILS -> Select System Email --> SMTP Settings.

Our current (not working) setup is:

SYSTEMS -> EMAILS -> Default outgoing email: our default email
EMAILS -> EMAILS -> Select System Email --> Mail Account --> Enable, imap.gmail.com, 993, IMAP, SSL
EMAILS -> EMAILS -> Select System Email --> SMTP Settings --> Enable, smtp.gmail.com, 587 (Also tried 465), YES

With this setup as soon as I try to save I receive
"authentication failure [SMTP: Invalid response code received from server (code: 535, response: Incorrect authentication data)]" error message.

I really appreciate if anyone could assist.

Thanks in advance...
 

Comments

  • Have you enabled IMAP and POP in google?
    http://support.google.com/a/bin/answer.py?hl=en&answer=105694

    Have you checked your php error log?
    Have you opened the relevant ports through your firewall?
    Have you searched the forums?

    Is your PHP compiled with imap and mcrypt? (Or if running Windows for your server have you enabled those extensions)

    I direct you to Google's help:
    https://support.google.com/mail/troubleshooter/1668960?hl=en

    I also direct you to:
    http://osticket.com/wiki/Email_Settings
    (Scroll to the Gmail section)

    I also direct you to:
    http://blog.rudeotter.com/2014/01/gmail-google-apps-smtp-relay-osticket.html
  • Hi ntozier,

    Thank you for very detailed info.
    After having searches I have found out it might be a hosting, firewall, port issue rather then being an OsTicket.
    By changing and testing the setup we'made it worked.

    However, I am not sure about right settings. I really appreciate if you could confirm.

    SYSTEMS -> EMAILS -> EMAIL POLLING ->INCOMING EMAILS: Should I check "Enable POP/IMAP polling" or clear?
    SYSTEMS -> EMAILS -> DEFAULT EMAIL -> OUT GOING EMAILS: Which one? "None - Use PHP mail" or our default email?
    EMAILS -> EMAILS -> Our system email--> Mail Account: Enable or Disable?
    EMAILS -> EMAILS -> Select System Email --> SMTP Settings --> Enable or Disable?

    This is why I'm asking. We have an otner probkem now. We cannot receive notifications of tickets arrived in our support (the ones sent via email. I not use about the ones sent thru support system web page). As soon as any system user logs into the system, something happens and triggered, all tickets saved in the system with the date/time user logs in and notification messages to admin dispatched.

    Thanks for your help in advance.

    -Jale
  • Please see attached files
    screen1.jpg
    1366 x 768 - 205K
    screen2.jpg
    1366 x 768 - 181K


  • Your emails settings are really up to you and how you want to configure it.  If they workj for you the way that you want to send receive mail then they are right.

    SYSTEMS -> EMAILS -> EMAIL POLLING ->INCOMING EMAILS: Should I check "Enable POP/IMAP polling" or clear?

    Enable POP/IMAP polling
    This option requires that you have setup cron.  HAve you?
    If you have not then you will have to use "Poll on auto-cron" to get emails to fetch.
    Emails will only fetch on staff activity, and if no one is logged in no emails will be fetched.

    SYSTEMS -> EMAILS -> DEFAULT EMAIL -> OUT GOING EMAILS: Which one? "None - Use PHP mail" or our default email?

    Depends on if you want to send using PHPmail on the webserver (some hosts do not allow this), or through an SMTP server.

    EMAILS -> EMAILS -> Our system email--> Mail Account: Enable or Disable?

    Do you want to collect email from this address?  If yes, then it should be enabled.

    EMAILS -> EMAILS -> Select System Email --> SMTP Settings --> Enable or Disable?

    Do you want to send email via SMTP with this address?  If yes, then it should be enabled.  If you are going to use PHPMail then you can disable this.
Sign In or Register to comment.