Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion

osTicket v1.10 (stable) and Maintenance Release v1.9.15 are now available! Go get it now

Upgrade from 1.8.2 to 1.9 is giving db errors

I am not able to upgrade from 1.8.2 to 1.9, it gives me following error and upgrade halts in between. [ALTER TABLE `ost_filter` ADD `topic_id` int(11) unsigned NOT NULL default '0' AFTER `form_id`] Duplicate column name 'topic_id' I've followed the procedure mentioned on the wiki
Tagged:

Comments

  • 1.8.2 IS 1.9 (it was renumbered because of the number of new features), and 1.8.2 was never actually released except as a developer preview release.... So are you sure that you are running 1.8.2?



  • I am sorry it was 1.8.1.2
  • edited May 2014
    Hmm.  I didn't have that problem going from 1.8.1.2 to 1.9.

    The upgrader is trying to alter the ost_filter table, by adding a topic_id column, and that column already exists.

    This column was added in 1.9 to that table, so if you already have it then it appears that you already upgraded that database to 1.9.  Did you install 1.9RC and then change the code back to 1.8.1.2?  Or are you pointing to the wrong database or something?

    The file that adds it is: include\upgrader\streams\core\f5692e24-4323a6a8.patch.sql
    on line 61.
  • Yeah i had tried upgrading it to 1.9RC earlier, but even that failed, hence i had restored it back to 1.8.1.2
  • Do i need to remove only this line or there will be multiple, since i had tried to upgrade it on 1.9RC.
  • You can try running the upgrade sql manually and see what you have to remove fom the script to get the rest of the items done.  If you upgraded to 1.9rc (and didn't restore) there may be multiple lines.... there are no difference from 1.9rc to 1.9.0 database wise though... so.. weird.
Sign In or Register to comment.