Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion

osTicket v1.10 (stable) and Maintenance Release v1.9.15 are now available! Go get it now

Upgrade from 1.8.3 to 1.9 issues

G'day guys,

I'm trying to upgrade from osTicket 1.8.3 to 1.9 but I keep getting the following error - see attached

I always upgrade using Installatron on cPanel hosting, works every other time.

Now I'm getting this error after I login to /scp/admin.php and click on Upgrade (Obviously 1.9 has database changes)

 Upgrader - 4323a6a8 (task pending).

The TemplateContentLoader task reports there is work to do

Any ideas guys?

Steve
image
«1

Comments

  • edited May 2014
    This is what the upgrade.php is stuck on - see attached

    P.S. can anyone else see the first attached screen shot? I can see it if I edit the post, but not if I check the discussion. If not I'll repost it.
    osTicket-upgrade-issue#2.png
    956 x 487 - 60K
  • Ok I got the first picture to work
  • edited May 2014
    Are you getting any errors in your php error log?

    If you cannot get to the php error logs, or want to display errors on the screen instead you can also use the directions here: http://www.tmib.net/osticket-v19x-frequently-asked-questions-faq#2

    I'll point out this thread to the devs, but with out an error I'm, not sure that we can do to actually assist you.
  • Thanks for the response @ntozier, I have tried to retrieve my cPanel php log, but it stopped working as of the 17-Apr-2014. 

    I'm in contact with my hosting provider at the moment, I will post back anything relevant ASAP.
  • Ok seeing that I have tried to upgrade and it failed, the Installatron restore doesn't delete the old entries in MySQL. So this time I got this error:

    [RENAME TABLE `osti_page` TO `osti_content`] Table 'osti_content' already exists

    I'll try to remove that table before I upgrade and see what happens
  • Ok I have followed your directions for turning on php errors in bootstrap.php. No real difference actually, the errors are these now if I remove that database table osti_content

    DB Error #1146

    [ SELECT id FROM osti_content WHERE `type`='banner-staff'] Table 'USERNAME_osti1.osti_content' doesn't exist

    ---- Backtrace ----
    #0 (root)/include/mysqli.php(163): osTicket->logDBError('DB Error #1146', '[ SELECT id FRO...')
    #1 (root)/include/class.page.php(218): db_query(' SELECT id FROM...')
    #2 (root)/scp/login.php(22): Page::getIdByType('banner-staff')
    #3 (root)/scp/staff.inc.php(55): require('/home/USERNAME/...')
    #4 (root)/scp/staff.inc.php(71): staffLoginPage('Authentication ...')
    #5 (root)/scp/tickets.php(17): require('/home/USERNAME/...')
    #6 (root)/scp/index.php(17): require('/home/USERNAME/...')
    #7 {main}


    Then a little later it says this:

    Upgrader - 4323a6a8 applied

    Patch f5692e24-4323a6a8 applied successfully (v1.9.0)

    Straight after that it says this and keeps on going indefinitely:

    Upgrader - 4323a6a8 (task pending).

    The TemplateContentLoader task reports there is work to do
  • edited May 2014
    G'day guys,

    I still can't upgrade to 1.9 or even to 1.9.1 (didn't surprise me since there were no database changes)

    What I can say is that when I do upgrade it must fail on this upgrade task:

    Add organization features

    When I enable logging it shows up this at the top of the screen at ~/support/scp/logs.php

    Warning: Cannot modify header information - headers already sent by (output started at /home/USERNAME/public_html/support/include/staff/header.inc.php:72) in/home/USERNAME/public_html/support/include/staff/header.inc.php on line 80

    please help guys - @peter and @ntozier - although I am sure you are busy

    regards,
    Steve
  • I did just realise that my host is running LightSpeed (Drop in replacement for Apache)
  • Have you tried upgrading to 1.9.1 (released last night)?

    It sounds like your ost_content table does not exist.  Can you look in your data base and see if the ost_page table exists?  1.9.0 renames this table to ost_content.

    The SQL for this is located in /include/upgrader/streams/core/f5692e24-4323a6a8.patch.sql on lines 69 through 76.
  • G'day @ntozier,

    Yeah I did, see above post. 

    Even if I remove osti_content I still get an error, but if I don't remove it I get the dreaded:

    [RENAME TABLE `osti_page` TO `osti_content`] Table 'osti_content' already exists

    Here is a screen shot of my database:
    osTicket_1.8.3_to_1.9.1_issues.png
    996 x 924 - 214K
  • What error do you get if you remove the table?
  • Hi,

    I got the same errors as you before I figured out the real issue.

    I initially downloaded the latest release from GitHub and tried to upgrade as per the instructions, I eventually discovered that there was no upload folder in the download from Git, so I looked for another download. I stumbled upon the download on osTicket website itself.

    I downloaded it from here http://osticket.com/download and I found that it contained the upload folder. Luckily I kept a copy of my old application files so I reverted and confirmed that everything still worked. I then copied all contents over the old install and it upgraded with no problems (don't forget to copy over the old ost-config.php from the previous install)

    Hope this helps.

    Thanks.
  • @hakim_z unfortunately that did NOT work for me. 

    I do appreciate the effort though.
  • I have exactly the same issue when upgrading from 1.8.2 to 1.9.x (both .0 and .1 give me the same problem).

    I tried what was suggested above and it didn't work for me either. I also have the ost_page table before the upgrade but as for sjswarts renaming it doesn't help. Any help is appreciated, I look forward to testing the customer-facing improvements.
    osticket_182_to_191_upgrade_error_2.PNG
    878 x 357 - 49K
  • @sjswarts your answer does not address my question, so let me clarify.
    If you remove the the ost_pages table, what error are you getting?
  • Oh ok @ntozier I will remove that table. Do I keep ost_content or remove that aswell?
  • Presuming you ran the SQL code the ost_page table should have been renamed ost_content.  So you need an ost_content table.

  • Attached osticket_db_183.txt lists the tables in the 1.8.3 database

    1) running the upgrader from scp on the 1.8.3 fails, with system log listing

    Upgrader - 4323a6a8 (task pending).

    The TemplateContentLoader task reports there is work to do

    as shown in the screenshots in above posts. Somewhat later it will also show an entry

    DB Error #1146

    [ SELECT id FROM ost_content WHERE `type`='banner-staff'] Table 'osticket.ost_content' doesn't exist

    ---- Backtrace ----
    #0 (root)/include/mysqli.php(169): osTicket->logDBError('DB Error #1146', '[ SELECT id FRO...')
    #1 (root)/include/class.page.php(218): db_query(' SELECT id FROM...')
    #2 (root)/scp/login.php(22): Page::getIdByType('banner-staff')
    #3 (root)/scp/staff.inc.php(55): require('/srv/www/htdocs...')
    #4 (root)/scp/staff.inc.php(71): staffLoginPage('Authentication ...')
    #5 (root)/scp/admin.inc.php(16): require('/srv/www/htdocs...')
    #6 (root)/scp/logs.php(16): require('/srv/www/htdocs...')
    #7 {main}

    2) the table ost_page looks to have been renamed to ost_content at this point - attached osticket_db_failed_upgrade_191.txt lists the tables in the osticket database

    3) deleting the ost_page table before the upgrade results in the upgrade process failing with

    [core]: Upgrader Error

    [RENAME TABLE `ost_page` TO `ost_content`] Can't find file: './osticket/ost_page.frm' (errno: 2)

    Please let me know what other information would be helpful.

    @sjswarts @ntozier not my intention to hijack the thread, i didn't think there was a point in opening a second thread for the same issue but if you prefer I can do that. Thanks to both for your efforts.
    osticket_db_183.txt
    1K
    osticket_db_failed_upgrade_191.txt
    2K
  • No drama mate, I haven't had time to look into as yet will in the next few days however
  • I'm also having this issue trying to upgrade to 1.9.1.  I haven't had any mods since 1.7.  Everything is stock 1.8.1.2, except 1 line of code, which only is cosmetic. I also got the DB Error #1146

    [ SELECT id FROM ost_content WHERE `type`='banner-staff']
    
    Table 'osTicket.ost_content' doesn't exist<br />
    <br />
    ---- Backtrace ----<br />
    #0 (root)/include/mysqli.php(169): osTicket->logDBError('DB Error #1146', '[ SELECT id FRO...')<br />
    #1 (root)/include/class.page.php(218): db_query(' SELECT id FROM...')<br />
    #2 (root)/scp/login.php(22): Page::getIdByType('banner-staff')<br />
    #3 (root)/scp/staff.inc.php(55): require('/home/xxxxxxxx/...')<br />
    #4 (root)/scp/staff.inc.php(71): staffLoginPage('Authentication ...')<br />
    #5 (root)/scp/admin.inc.php(16): require('/home/xxxxxxxx/...')<br />
    #6 (root)/scp/upgrade.php(16): require_once('/home/xxxxxxxx/...')<br />
    #7 {main}
    

    Just wanted to add another verification of the issue.  I had to revert back to my backup.  I can take another stab at this in the next few evenings.
    --utopiasedge
  • @ntozier - if I remove ost_pages and LEAVE ost_content it errors with this

    [RENAME TABLE `osti_page` TO `osti_content`] Table 'osti_content' already exists  

    very annoying. Can we please get developer support? It looks like I'm not the only person suffering from this.
  • Reading through that *.patch.sql I can't seem to find any place that would cause it to stop working. Is there anyway to see at what point the commands get stuck?

    Upgrader - 4323a6a8 (task pending).

    The TemplateContentLoader task reports there is work to do


    What is the "TemplateContentLoader" ??
  • Re: Can we please get developer support? It looks like I'm not the only person suffering from this.

    This thread was pointed out to the devs on May 27th.

    What is the "TemplateContentLoader" ??

    I imagine that its a function that loads the templates if they haven't already been loaded.


  • @ntozier is there a way to manually update the changes to the database? Then upgrade using the normal way but telling the upgrade script that the database has already been upgraded?

    Either that or can I start a complete new system and import all my tickets and data?

    That would be a great function, to internally backup and be able to restore on a fresh install.
  • You would have to restore your database from back up to revert to pre making changes.

    There is no way to automatically regress, or import all your tickets into a newer version at this time,
  • G'day @ntozier @peter and whoever else is in the know,

    I'm patiently waiting for any help that is available. I realize that its provided free and support is limited but there does appear to be a fair few people who are suffering from this.

    Anything that I can do to resolve this?

    Steve
  • Have you tried restoring and upgrading to 1.9.1 instead or perhaps development-next?
  • I have tried upgrading straight from 1.8.1.2 to (1.9.0|1.9.1) and no luck

    I have not tried the development-next, I presume that is on GitHub?
Sign In or Register to comment.