Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion

osTicket v1.10 (stable) and Maintenance Release v1.9.15 are now available! Go get it now

[resolved] MySQL minor upgrade: Offline & can't login

I upgraded MYSQL from 5.5.12 to 5.5.19 this morning. When I browse to the client portal it says, "Ticketing System Offline" and I cannot log into /scp. I am using AD authentication but login screen says, "Access Denied". Database, tables, and data are all there. The MySQL user has full access to the osTicket database.

Is there some type of hash in the osticket config file (secret_salt?) that needs to be synched that tied my osTicket installation into MySQL? I did clear my cache and tried 2 different browsers with no luck.

My 2 other web applications tied into that MySQL installation are working fine.

osTicket 1.9

MySQL 5.5.19

Comments

  • edited June 2014
    Well, I figured this out...

    Databases were there, tables were there, user accounts were there yet when I ran a SELECT * FROM _table_" It came back, "_table_ doesn't exist" (even though I could see they were physically there)...

    This had to do with the transaction logs in the data directory. Somehow these got messed up during the upgrade, but thank god I had a good backup. I simply copied all the ib* files from the backup (there were three in my case) and overwrote the new log files that were created during the upgrade.

    Always good to properly backup and data dump before an upgrade...
  • +1 for very sound advice.  I'm glad that you got this working. I'm going to mark this resolved and close this thread, please feel free to start a new thread if you have another question/comment/etc.
This discussion has been closed.