Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion

osTicket v1.10 (stable) and Maintenance Release v1.9.15 are now available! Go get it now

1.9.1 - Layout Issues when Editing Email Templates

When one select a different font type of to insert a new table in the text box, the dropdown menu is overlapped with the title and part of the text box area. Any ideas how to overcome this?

See attached file for a better explanation.




Thanks in advance,
C

Comments

  • Not sure why the image file is not being attached :(image
    2014-06-03 16_03_27-osTicket __ Admin Control Panel.png
    956 x 430 - 23K
  • By the way, I tried this with different web browser and the problem persist.
  • I found this: In \included\staff\tpl.inc.php

    <div style="padding-bottom:3px;" class="faded"><strong>Email Subject and Body:</strong></div>
    <div id="toolbar"></div>
    <div id="save" style="padding-top:5px;">
        <input type="text" name="subject" size="65" value="<?php echo $info['subject']; ?>"
        style="font-size:14pt;width:100%;box-sizing:border-box">
        <div style="margin-bottom:0.5em;margin-top:0.5em">
        </div>
        <input type="hidden" name="draft_id" value=""/>
        <textarea name="body" cols="21" rows="16" style="width:98%;" wrap="soft"
            data-toolbar-external="#toolbar"
            class="richtext draft" data-draft-namespace="tpl.<?php echo $selected; ?>"
            data-draft-object-id="<?php echo $tpl_id; ?>"><?php echo $info['body']; ?></textarea>
    </div>

    I know a little bit about html programming so here is my question. Is it possible to make a change in the textarea or the toolbar portion so the toolbar dropdown menu does not populate behind the textarea box?

    Please help!

  • Seems to be a general issue. Reported it via github and Jared (one of the developers) offered a fix: https://github.com/osTicket/osTicket-1.8/issues/980

    You can try it the offered fix, will try myself tomorrow.
  • edited June 2014
    Yes, the fix works. THANK YOU SO MUCH!

    Specially the redactor-font.js file change fixes the problem. I went ahead and tried to apply all these 5 fixes related to the issue #980

    The only file I could not update was css/redactor-font.eot  I could not figure out how to get it. It says: Binary file not shown. Other than that I updates the remaining 4 files.

    Any help updating this last file?

    Thanks!
  • Chefkeks, Do you forsee a new release (say 1.9.1.1) anytime soon? this bug is kind of important to have sort out for a stable release. The reason why I asking, is because I could wait a few weeks if a new release is being planned. I just don't want to waste my team in customizing this v1.9.1 to find a few weeks a new release addrssing this and some other bugs that I have not encountered yet.

    Thanks in advance for your insight.
  • @C4rloco, the url posted by Chefkeks to the bug report also contains the fix.
  • @C4RLOCO
    Sorry, I am not involved in the osticket development nor part of the development nor a forum moderator / part of the forum team, only a huge osticket enthusiast :D :D :D

    So I suggest joining the osticket mailing list to get notified of new releases (can't find the URL to sign up right now, just search the forum or google it) and wait for new releases.

    Btw. I applied the fix by copying the whole osTicket directory, replacing the 5 files and since I used a symbolic link to the directory of my osticket installation on my apache webserver, I just changed this symlink to point to the new osticket install dir which include the fix. In case of e.g a new bug I would then be able to switch back really fast this way to the original 1.9.1 osticket installation.
  • Thanks @chefkeks
    @peter @ntozier any insights?

    Thanks in advance,
    C
Sign In or Register to comment.