Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion

osTicket v1.10 (stable) and Maintenance Release v1.9.15 are now available! Go get it now

DB error after upgrading from latest 1.8.x to 1.9.1

Hi there,

I've ugraded from latest 1.8.x to 1.9.1 and all seems working fine but I received two mails with this db error:

[ SELECT id FROM ost_content WHERE `type`='banner-staff']

Table 'nabiri_osticket.ost_content' doesn't exist<br />
<br />
---- Backtrace ----<br />
#0 (root)/include/mysqli.php(169): osTicket->logDBError('DB Error #1146', '[ SELECT id FRO...')<br />
#1 (root)/include/class.page.php(218): db_query(' SELECT id FROM...')<br />
#2 (root)/scp/login.php(22): Page::getIdByType('banner-staff')<br />
#3 (root)/scp/staff.inc.php(55): require('/home/nabiri/pu...')<br />
#4 (root)/scp/staff.inc.php(71): staffLoginPage('Authentication ...')<br />
#5 (root)/scp/tickets.php(17): require('/home/nabiri/pu...')<br />
#6 (root)/scp/index.php(17): require('/home/nabiri/pu...')<br />


AND

[ SELECT id FROM ost_content WHERE `type`='banner-staff'] Table 'nabiri_osticket.ost_content' doesn't exist<br /> <br /> ---- Backtrace ----<br /> #0 (root)/include/mysqli.php(169): osTicket->logDBError('DB Error #1146', '[ SELECT id FRO...')<br /> #1 (root)/include/class.page.php(218): db_query(' SELECT id FROM...')<br /> #2 (root)/scp/login.php(22): Page::getIdByType('banner-staff')<br /> #3 {main}

What I have to do?


Comments

  • I don't have any answers for you, but just wanted to chime in that I had the same error after I attempted to upgrade from 1.8.1.2 to 1.9.1.  I have had to restore my backup back to previous version for now.

    ost_content DOES in fact exist in my system, however, I notice that it does NOT contain a "banner-staff" type as referenced in the error message.  I'm not sure what to do about it ... hoping someone else can shed some light for us.
Sign In or Register to comment.