Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion

osTicket v1.10 (stable) and Maintenance Release v1.9.15 are now available! Go get it now

Users can't view ticket progress via Link in "Support Ticket Opened" email

The email users are sent after opening a ticket contains a link that says, "View this ticket's progress online". But clicking it brings me to a 404 error. If you hover over the URL, it contains the correct IP address for my helpdesk server where my IIS hosted OSticket page is the default page. (Environment: Server 2008r2, IIS, mysql)

404 - File or directory not found.

The resource you are looking for might have been removed, had its name changed, or is temporarily unavailable.

Did i miss a step?


  • edited June 2014
    I figured part of it out. I'll post what i know so far. I have an IIS server and could only get the site to work using a redirect htm page that forwards you from [IIS Server Name] to [IIS Server Name]/helpdesk

    The email template for "Support ticket opened" has a template that references "%{recipient.ticket_link} that translates to " etc" when sent to the user. I need to add "/helpdesk" after the IP address for it to work, but since the link is masked using "%{recipient.ticket_link}", i haven't found a way to fix it yet.

    Here are my 3 possible choices.
    1. "Fuck you users, no ticket updates for you"
    2. Fix IIS so I don't need IIS to redirect me to the correct page.
    3. Anyone know how to change this "%{recipient.ticket_link}" link?
  • Version of osTicket?
    I'd recommend that you shut off the redirect script.

    And have you seen this:

  • Wouldn't i have to start over and reinstall OSticket to change the path? Its on c:\inetpub\wwwroot\helpdesk right now, which corresponds with the [IIS server name]/helpdesk path.

    I don't know IIS that well, i'd rather change the "%{recipient.ticket_link}" link
  • Recipient link is based on the help desk url. The url can be updated/changed in Admin Panel > Settings.
  • well i'll be damned. That did it. Thanks peter!
Sign In or Register to comment.