Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion

osTicket v1.10 (stable) and Maintenance Release v1.9.15 are now available! Go get it now

Upgrading from v1.8.1.2 to v1.9.1

I'm trying to upgrade out osTicket.  Following the instructions (same as other upgrades) is not working.  When I try to upgrade, I am always redirected to install the system again.  I've tried forcing it to use the upgrade file, with no luck.  If I remove the install.php file, I receive an error saying to contact the admin.  

Any thoughts?

Comments

  • did you replace your ost-config after copying the new code into place?
  • Hello ntozier,
       Yes, I tried using the original file, updating the database information in the new file, and just using a blank copy of the new file.  All three would jump to the install.php, no matter what I tried.  

       I did try even moving forward with the install; but, it would not move forward with the install due to the database prefix already being used.  I'm stumped on why it won't register that the data is already there, and it should be an upgrade.

  • No offense but it sounds like you must have done something wrong.

    Put the files in the same place where the old files were. (copy over them if you want).
    Then put the ost-config.php from your back up in the /include folder.

    Clear your cache, and then load the site in a web browser.
  • I have to agree.  I kept thinking I did something wrong, as well.  I won't be able to try again till next Sunday.  i'll try it again, and see.

  • I'll leave this thread open, please update it and let us know how you make out.
  • Well, I just tried again (with 1.9.2 & 1.8.4)...  Still no luck.  If I do not copy the old includes/ost-config.php file over then the system tries to install a new instance (as expected).  If I do copy it over, and navigate to /support/setup/ It immediately goes to install.php.  If I actually attempt to force it to go to upgrade.php, it just sits at a white screen with nothing on it.  

    This is strange, as it has never happened before...  I'm going to continue looking to see if I can find the cause; but, at the moment, no luck...  Thanks...
  • So, just as a test - I went ahead and created a new instance.  It went through the install, and then still just gave me a white screen upon trying to move past the "finished" page...?  No luck adding in the php error reporting either, nothing gets reported...?

    Anyone have any thoughts?
  • Now I tried a completely new instance (with a new database) and it worked.  Maybe there was a database issue?  I'm going to try and shove my old data into this new database now.  If that works then I'll be good...  We'll see...

  • So, once I imported all of the data from my original osTicket DB, the system once again goes to just a blank white screen.  So, the issue has something to do with the database.  Any thoughts on that?  Changes to the DB structure in 1.9.2?

    Thanks for any further assistance.

  • I may have found a workaround.  I went ahead and copied all table data (other than the ost_config table) form old to new, and the new instance is working.  I did notice a lot of db changes, though.  Guessing that is what is causing the problems?

Sign In or Register to comment.