Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion

osTicket v1.10 (stable) and Maintenance Release v1.9.15 are now available! Go get it now

Upgrade 1.6ST -> 1.9.2 Fails miserably

Hello yall,

we've been running a 1.6ST version of OSticket for some time now, and i'd like to upgrade it to the latest version 1.9.2. I am however having some difficulties with this. Here is what i tried so far:

I made a backup of my current running config using DirectAdmin. Since we have more then one server i restored it on a different and newer server, to keep the original version running while i iron out the issues with the upgrade. The specs of the original server are:
Apache 2.0.64 Server
DirectAdmin 1.40.3
Exim 4.72
MySQL 5.0.81
Named 9.3.6
ProFTPd 1.3.3d
sshd
dovecot 2.0.11
Php 5.2.17
OSTicket 1.6ST

The specs of the new server are:
Apache 2.2.22
DirectAdmin 1.40.3
Exim 4.77
MySQL 5.5.20
Named 9.7.3
ProFTPd 1.3.3e
sshd
dovecot 2.1.1
Php 5.3.26

So i exported the backup on the first and restored it on the second, and after altering my local hosts file, i have a exact replica of the original. After that i downloaded the last stable version (v1.9.2), overwriting the files on my new server using FTP and putting back the original ost-config.php. After that i was neatly presented with a upgrade screen when i tried logging in on my SCP. 

Now here it gets nasty. All the checks are green so i proceed, after that i get a complete list of version upgrades, again i proceed. Almost immediately i get a upgrade error:

-- do not edit --

[INSERT INTO `ost_team` (`lead_id`, `isenabled`, `noalerts`, `name`, `notes`, `created`, `updated`) VALUES (0, 1, 0, 'Level I Support', '', NOW(), NOW())] Duplicate entry 'Level I Support' for key 'name'

After that my mailbox gets flushed with DB error #1054 and #1146. So i think maybe i should take baby steps. I restore my backup again, so i am back to a running version of 1.6ST. After that i downloaded v1.7.0 after reading that i sometimes could solve upgrading issues (http://osticket.com/forum/discussion/77583/updating-from-1-6st-to-newer-versions#latest). No joy, i again get the same error as above, although no error #1054 and #1146 in my mailbox this time. Weird. So i think: well, maybe there already is a entry in my DB as the Upgrader Error suggests. Nope, ost_team is very empty. No records at all. So, i am a bit stumped at the moment... Any suggestions?

Kind regards,

John.


Comments

  • The error quite literally says:
    "I tried to insert this record... but it already exists."
    You can delete the record manually, and it should move right along. There may be other things that it also complains about...
  • Yeah, that's what i thought. But as i mentionned; the table ost_team is empty. There are no records in ost_team... so how could there be a duplicate entry?
  • That's not possible. Are you sure that you are looking at the right database.
  • edited July 2014
    Double checked it; that's why posting my problem here ;)
  • MySQL wouldn't report a record as already existing if it does not already exist.
    So either there is something very wrong with your MySQL installation, or you are not looking at the right database.
Sign In or Register to comment.