Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion

osTicket v1.10 (stable) and Maintenance Release v1.9.15 are now available! Go get it now

Upgrade from 1.8.0.1 to 1.9.2 success but with errors

Hi,

Today, I upgraded osticket test environment on my virtual machine , from 1.8.0.1 to 1.9.2. This was to verify that the upgrade works without any issues, before I do the same on our production server. Here is the info about my test environment first (also attached image, just in case):

Server Information 
osTicket Version v1.9.2 (4827655) 
Server Software Apache/2.4.4 (Win32) OpenSSL/0.9.8y PHP/5.4.19 
PHP Version 5.4.19 
MySQL Version 5.5.32 
PHP Extensions  gdlib Used for image manipulation and PDF printing 
 imap Used for email fetching 
 xml XML API 
 xml-dom Used for HTML email processing 
 json Improves performance creating and processing JSON 
 gettext Improves performance for non US-English configurations 
 mbstring Highly recommended for non western european language content 
 phar Highly recommended for plugins and language packs 
 PHP Settings  cgi.fix_pathinfo =  "1" is recommended if AJAX is not working   
Database Usage 
Database Space Used 2.09 MiB 
Database Space for Attachments 0.03 MiB 

This is implemented on Windows Server 2008 (x64) - Test environment
Now the issue is, I upgraded as per the instructions, replaced the files in 'upload' folder with the files in 'upload' folder from 1.9.2. Copied the same ost-config.php file from old 1.8.0.1 directory. Executed the upgrade script from osticket admin panel and it showed as 'success'. 
Then I added 'File System' plugin as well, which was also added successfully too.

1. When I tried to add in a new user from client portal, I fill up the form and click 'Submit' , it gives page not displayed error. I refresh the page, and I tested to create a account with this same user id again, it shows user already registered error. So I try to login with this id, it shows confirmation required, but I didn't get any email in my test user inbox.

2. I created a ticket (browser is both Chrome and IE 8), attached a file (to test file system plugin) and click on 'Submit'. The page goes all blank (white), waited for few minutes but nothing shown, so I refreshed also.
Then I open staff panel and I see two tickets created (may be because I refreshed above), I click on each ticket and I can see the content and attachment too. Attachment is stored in correct folder on server, so this is tested fine, although it created two folders '1' and 's' and files with no extension, I checked other discussions on this so I understand this is not an issue as of now.
But I had already set up email alerts, so I am not receiving any email alerts. I also tested to send diagnostic email, but it also shows 'page not displayed' error after I click send.

3. I checked the logs, and noticed that few of the items were pending and 2 DB errors (DB error # 1146). Attached a screenshot for the same.

Appreciate any help, as we need to upgrade the latest version on live environment. 

Thanks,

Regards,
Rick 


Comments

  • Can anyone see the attachments ?
  • No, can't see the attachment.
    I am also having issues using the forum, seems to depend on the browser which is used to access the website/forum. Just try editing your post with another browser and attaching the image. I suggest Chrome since this is the browser which works best for me - IE is always a problem (at least for me), while mobile IE (from my Windows Phone) works like a charm xD :D
  • Attaching images again, in case if not visible 
    osticket system info 1.9.2.jpg
    764 x 494 - 111K
    osticket 1.9.2 system logs.jpg
    944 x 410 - 132K
    DB error 1146.txt
    1K
  • Chefkeks : Thanks for the reply!

    I used chrome earlier too. Now again added attachments using chrome, now it seems they are visible.
  • I found out that this discussion also had similar issues, but I couldn't figure out in the end what is the way to solve it:


    Any help ?
  • UPDATE:

    So, I followed the solution provided by sjswarts  in the discussion link I posted above and it worked. 
    At least, I'm able to send diagnostic email and create tickets.

    testing other functions now.

    though I'm getting the same DB error in logs as mentioned in the discussion link.
    Anyone has any updates on this ?

    Thanks,
    Rick
  • I believe deleting ost_content table is causing some issues.

    like, email alerts are not working now, new user registration template error in system logs

    Can anyone help in this ? Is there a way to re-create ost_content table and make the system act normal ?

    Thanks,

    Rick

Sign In or Register to comment.