Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion

osTicket v1.10 (stable) and Maintenance Release v1.9.15 are now available! Go get it now

ost-config.php

Hi! I'm trying to install osTicket 1.9.2 on a CentOS 6 server running under VirtualBox to test whether it's a good fit for my organisation. I've reached a part in the installation that I can't get past - I'm getting a message saying: osTicket installer requires ability to write to the configuration file include/ost-config.php

Now, I followed the previous step and renamed the original sample file, I've also used chmod a+w ost-config.php to make it writable, but I'm still getting this error.

Please help!

Comments

  • I know it's not recommended, but try to "chmod 777 include/ost-config.php" and check if the error still persists ;)
  • thanks! i restarted the server and tried the setup again and it went through fine. no idea what the problem was.

    now if i could just figure out how to configure osTicket to work with SMTP... ;)
  • SMTP, just look at: Email -> Emails in the admin panel, you can configure SMTP for every mail address there ;)
  • I'm also having this same issue. .../include/ost-config.php has proper permissions (I've tried 0666 and 0777.) I've tried rebooting since that seems to have worked for OP.

    This is on CentOS7 (also my first go around with version 7)

    Any other ideas? The installer just doesn't think it can write to ost-config.php, when it definitely should be able to.
  • @mrwboilers
    Please open your own thread.
    This thread is about a user who is running CentOS6, you are apparently not running the same version.

    Since your running CentOS I would recommend shutting of SELinux and trying again.  If that fixes your problem you can turn it back on and write a rule to fix it.
This discussion has been closed.