Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion

osTicket v1.10 (stable) and Maintenance Release v1.9.15 are now available! Go get it now

[resolved] Locked (Pending Activation)

trmtrm
edited November 2014 in Troubleshooting and Problems
Hey guys how do I manage these user accounts. Is there a way to manually activate them? How do I deal with the one that has no name? See pic attached.

Thanks,

Comments

  • no picture attached.
    They have to open the email that was sent to them and click the link.

  • sorry, I thought I attached the pic. Here it is.
    osticket error.PNG
    1269 x 402 - 34K
  • its not letting me attach for some reason. Here's a link. http://imgur.com/CKZVuOp

  • in order for the pending activation to go away they will need to click the activation link in the email they were sent.

    In order for you to have a name there you will have to add one.  You can do that a couple ways... the easiest is probably to look at the page source for the link and use that to get to the user page.  Some browsers if you mouse over the link will show you the link also.  If memory serves it will looks something like:
    users.php?id=XXX where XXX is the users internal ID.  So you would go to:

    domain.ext/scp/users.php?id=XXX

    Where you would be able to click on the icon to the right of the blank name spot to open the edit user window.

    The harder way would be to get the internal user ID and edit the database directly... which I wont even go into.
  • Wondering if someone could advise where in the database I could go to to manually activate client rather than have them click on an activation link.

    I am testing an instal offline  so the emailing steps are not working.

    Thanks
  • My guess is that it would be the status field in the ost_user_account table.
  • That's what I figured.  I switched the status in the ost_user table from 0 to 1 thinking that would work, but no such luck.
  • I believe that you would need to change the status to 1, and set a hash password in the passwd column for that row.
  • Turns out I was looking at the wrong table.  I needed to change the ost_user_account table and change user status from 0 to 1.

  • I'll mark this as resolved and close the thread.
    Please feel free to start a new thread if you have another question.
    Thanks for following up and letting us know how you made out.  Hopefully someone else will see this thread and it will also help them. :)
This discussion has been closed.