Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion

osTicket v1.10 (stable) and Maintenance Release v1.9.15 are now available! Go get it now

[resolved] Installation error, Unable to connect to MYSQL. MYSQL server has gone away


Hi i'm installing OsTicket on my local computer with the follwing specs
Windows 8Wamp Server-Apache 2.4.9-MYSQL 5.6.17-PHP 5.5.12
Error:Database connection information Unable to connect to MySQL server. MySQL server has gone away
The installation Seems to connect to MySQL server but i don't understand that error... the service stays up and running, i don't know if the OsTicket system is trying to create some objects in the database and is taking to long to respond. how can i debug this process?..

Comments

  • "Unable to connect to MySQL Server" generally means that it cannot connect to the MySQL server...

    Shut off your firewall on your Windows8 box. and try again.
    If that doesn't work:
    Check your MySQL Error logs to see if there is any reason why there.
    Check your PHP Error logs to see if there are any errors there.

    There have been a number of people using wampserver.com software that have had issues installing osTicket and every time it has been the configuration of the server.
  •  the weird thing is that my firewall is off and i don't have anything in the Apache's log and MySQL...

    anything else that i could check?
  • the PHP error logs
  • PHP Log

    [15-Jul-2014 16:50:51 UTC] PHP Warning:  PHP Startup: Unable to load dynamic library 'c:/wamp/bin/php/php5.5.12/ext/php_ldap.dll' - The specified module could not be found.

     in Unknown on line 0
  • Check to see if
    c:/wamp/bin/php/php5.5.12/ext/php_ldap.dll
    actually exists.

    If it does not, you will need to get the
    php_ldap.dll file from ... well some where.  Normally I would say php.net, but you're running wamp server so...
  • the library exists in the folder... :(
  • Well your installation of PHP doesn't seem to think so.  Maybe its a permissions thing?
  • i'm going to try to re install Wamp and use another version of PHP to see if the installation is successful 
  • I'd recommend that you installing Apache, PHP, and MySQL independently personally, but to each their own I guess. :)
  • It worked!... just resintalled the WAMP and disabled the Ldap extension for php in the wamp manager.

    Thanks man
  • Glad that you got that sorted out. :)  Should I close this thread and mark is as resolved then?
  • Hi,

    I having the issue in installing osticket 1.9.2 in my windows server.
    when i click on [install now] botton on browser it will load some time and i shows blank page if i reload that page again i am getting installation.php page.

    can any one sugges me what need to do

    Thank in advance
  • @jagadeeswar You would read and following this thread: Please read before requesting assistance when you post your own information about the issue that you are having.
  • yes @ntozier you can close it as resolved
  • i'm trying to make the installation in other server and i'm getting the same error even if i did all the changes that worked on the previous installation.. crap

    I don't know what to do anymore.. :(
  • Is it the same version of wamp server?  (I ask because different versions have been reported as having different results in the past).
  • the same version... 
  • Sounds like you have something else going on, firewall software, etc.
  • nothing, don't worry.. i just moved the database to the other server and is working fine. You can close this topic as resolved :D
  • Okay. :)  I'm glad that you got things working.  I've marked this thread as resolved and till close the thread.  Please feel free to start a new thread should you have another question, comment, etc.
This discussion has been closed.