Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion

osTicket v1.10 (stable) and Maintenance Release v1.9.15 are now available! Go get it now

[resolved] Mail Delivery failed

Hi,

in my system I'm using email piping, and all works fine, except when  new ticket is opened via email, the sender always receives a "Mail Delivery failed" email.


But still the same "failed" email is being sent.

Below please find the content of the email. It somehow suggests that adding the file  /var/log/newrelic/newrelic-daemon.log fails. However, I can't figure out why it would even want to do something with that file.

Would you be able to help me out?

Thanks a lot!

Gert

Mail delivery failed message:
************************************************************************************************************************
This message was created automatically by mail delivery software.

A message that you sent could not be delivered to one or more of its
recipients. This is a permanent error. The following address(es) failed:

  pipe to |/home/justcore/public_html/support/api/pipe.php
    generated by support@justcorebusiness.com

The following text was generated during the delivery attempt:

------ pipe to |/home/justcore/public_html/support/api/pipe.php
       generated by support@justcorebusiness.com ------

ERROR: log file '/var/log/newrelic/newrelic-daemon.log' could not be opened - cannot continue.

------ This is a copy of the message, including all the headers. ------
************************************************************************************************************************

Comments

  • Hi,

    I just wanted to add that I tried a brand new installation, but I still get exactly the same error.

    I have no idea why and where the error

    ERROR: log file '/var/log/newrelic/newrelic-daemon.log' could not be opened - cannot continue
    occurs, and why there's a reference to the log file.

    Thanks for any help.
  • I would recommend that you check the permissions on your log file, that your mail server is telling you that it cannot open.  Specifically: /var/log/newrelic/newrelic-daemon.log
  • Hi ntozier,

    I did that, and actually I also tried to both rename and delete the file, but same result.

    My problem is this: Why would osTicket even try to do something with this file?

    For trouble shooting purposes, I even removed newrelic completely from my system, but I still run into the same problem. I also tried a brand new separate installation of osTicket, but still, same problem again.

    Other than this issue, I have literally no problems at all with my emails, so I tend to believe it's related to osTicket, but I can't really "nail that down"...
  • Hi ntozier,

    I finally figured it out (or actually the amazing support team from my hosting company dotblock.com did). You were right after all, the permissions for the log file needed to be set to 666, all works well now.

    Sorry for even mentioning it here, the error is totally unrelated to osTicket, it only occurs because osTicket happens to be the only program where I use email piping.

    Thank you anyway for looking into it, much appreciated.
  • Very welcome.  I'm glad that I could point you in the right direction. :)

    I'll mark this thread as resolved and close it.  Please feel free to start a new thread if you have another question, comment, etc.
This discussion has been closed.