Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion

osTicket v1.10 (stable) and Maintenance Release v1.9.15 are now available! Go get it now

Error when setting up for Outgoing email via SMTP

I am setting up osTicket for Outgoing email via SMTP. The Mail Server used is Lotus Domino. I follow the steps as follows

1. Admin Panel->Emails->Select my email address cap12_ehr@dh.gov.hk.

2. On the "Email Address/Update Email" screen, enter the following information.

Email Login Information

Username:Eric HL SO/DH/HKSARG

Password:******

Sending Email via SMTP

Status:Enable  

Hostname:10.13.101.51

Port Number:1352

Authentication Required:Yes

3. Click "Save Changes" button.

After I have clicked the "Save Changes" button, the following error messages are shown.

The Web page cannot be displayed.  HTTP 500

Pls see the attached screen dumps for the screen that I inputted the information above and the error page that I got. There is also another screen dump showing the configuration of my osTicket installation.

Configuration of my osTicket installation

==============================

OS:Windows Server 2008 R2 Enterprise

osTicket Version:v1.9.2 (4827655)

Server Software:Apache/2.4.10 (Win32) PHP/5.5.14

PHP Version:5.5.14

MySQL Version:5.6.19

 

Anyone can help? Thanks a lot!

 

Rgds/Eric So

 

Comments

  • You have to have a look at PHP error log.
    Maybe it's related to spaces in username...
  • Thank you very much, DiegoZuccato.

     

    I have checked the PHP error log file and I found the following error messages.

    =====================================

    [Wed Aug 06 15:37:17.085937 2014] [:error] [pid 3368:tid 896] [client 10.13.236.37:60115] PHP Warning:  mail(): Failed to connect to mailserver at "localhost" port 25, verify your "SMTP" and "smtp_port" setting in php.ini or use ini_set() in C:\\Apache24\\htdocs\\include\\pear\\Mail\\mail.php on line 153, referer: http://10.13.143.240:88/scp/tickets.php?id=5
    [Wed Aug 06 15:55:12.038086 2014] [:error] [pid 3368:tid 892] [client 10.13.236.37:60236] PHP Warning:  mail(): Failed to connect to mailserver at "localhost" port 25, verify your "SMTP" and "smtp_port" setting in php.ini or use ini_set() in C:\\Apache24\\htdocs\\include\\pear\\Mail\\mail.php on line 153, referer: http://10.13.143.240:88/login.php
    [Wed Aug 06 15:58:47.627929 2014] [:error] [pid 3368:tid 956] [client 10.13.236.37:60272] PHP Warning:  mail(): Failed to connect to mailserver at "localhost" port 25, verify your "SMTP" and "smtp_port" setting in php.ini or use ini_set() in C:\\Apache24\\htdocs\\include\\pear\\Mail\\mail.php on line 153, referer: http://10.13.143.240:88/view.php
    [Wed Aug 06 16:33:35.520507 2014] [:error] [pid 3368:tid 892] [client 10.13.236.37:60532] PHP Warning:  mail(): Failed to connect to mailserver at "localhost" port 25, verify your "SMTP" and "smtp_port" setting in php.ini or use ini_set() in C:\\Apache24\\htdocs\\include\\pear\\Mail\\mail.php on line 153, referer: http://10.13.143.240:88/scp/tickets.php?id=5
    [Thu Aug 07 10:06:14.804687 2014] [:error] [pid 3368:tid 896] [client 10.13.236.37:50500] PHP Warning:  mail(): Failed to connect to mailserver at "localhost" port 25, verify your "SMTP" and "smtp_port" setting in php.ini or use ini_set() in C:\\Apache24\\htdocs\\include\\pear\\Mail\\mail.php on line 153, referer: http://10.13.143.240:88/scp/settings.php

    =====================================

     

    I have set the values of SMTP and smtp_port in php.ini to the IP Address and port number of our Mail Server respectively as follows. Then I do the outgoing email setting again. But I still got the same error message - "The Web page cannot be displayed. HTTP 500".

    [mail function]

    SMTP = 10.13.101.51

    smtp_port = 1352

     

    Have I set the values of SMTP and smtp_port in php.ini correctly?

  • My guess would be that your web server does not have permission to talk to your mail server (because of a fire wall, or something).  Or your mail server does support POP or IMAP.
Sign In or Register to comment.