Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion

osTicket v1.10 (stable) and Maintenance Release v1.9.15 are now available! Go get it now

[resolved] using SSL (https://) also for Email Access Link

Hi,

As a new and enthusiastic osTicket user I am using osTicket 1.9.3 on an Apache server.

I prefer to have our system access encrypted by SLL.
So far it’s all good except for the ‘email access links’ as communicated by email to the user.

Here’s some introduction:
I have set the ‘standard’ rewrite rules into .htaccess

For example:
RewriteEngine On
RewriteCond %{SERVER_PORT} =80
RewriteRule ^(.*)$ https://%{SERVER_NAME}%{REQUEST_URI}

This results in converting all requested output presented via HTTPS://
And it works nice for the best part of osTicket.
However… not for the Email Access Links as communicated in the emails to the users.

These links are offered as;
http://mydomain.com/osticketfolder/view.php?auth=o1xaiaaaabiaaaaaGXKLMMV3haxmHA==

While using this link, as expected, the server rewrites it into:
https://mydomain.com/osticketfolder/view.php?auth=o1xaiaaaabiaaaaaGXKLMMV3haxmHA==

This results in the ‘Check Ticket Status’ screen again where the user can ask for a new access link…
(presented in http://... not allowing access again…)

This might be caused by osTicket noticing the difference between the original generated http link and therefore refusing access for the https link.

So here’s my request for assistance:

Would you have a suggestion how to set the system to either accept both HTTP and HTTPS as a start in the email access link or (even better) make osTicket generate HTTPS access links to send to the user?

Thanks for thinking along…
Ed

Comments

  • edited August 2014
    Problem solved without any modification.

    Simply go to the admin panel.

    Settings, System, (System Settings and Preferences)

    and update:

    "Helpdesk URL" into "httpS://mydomain/osticketfolder/
  • +1

    I'll mark this as resolved and close it.  You actually found the answer before I got a change to post it.  Good job!  Please feel free to start a new thread if you have another question or comment.
This discussion has been closed.