Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion

osTicket v1.10 (stable) and Maintenance Release v1.9.15 are now available! Go get it now

1.9.3 directory troubles!

Hi, 

I've installed version 1.9.3 on IIS and things seem to have gone ok generally, however the "welcome to the support center page" doesn't display properly.  That's accessed at http://servername/support ;

One thing i have noticed is that when i hover over certain links, e.g. "Support Center Home" it shows that the link is http://servername/index.php and i think it should be http://servername/support/index.php.  I'm guessing my page isn't displaying properly due to osticket not navigating links properly on my machine.

I'm a bit puzzled, because http://servername/support and http://servername/support/scp appear to land at the right place. 

Anyone have any advice please?!

thanks, 

Kevin 

Comments

  • Please check your:
    Admin panel -> Settings -> Helpdesk URL:

  • I have a common problem, as my url http://support.curvefever.com/scp also lands on http://support.curvefever.com instead of http://support.curvefever.com/scp/index.php . Is there a mistake with the .htaccess of os ticket?
  • The admin panel helpdesk url is correct:  http://servername/support. ;
    The customer portal page displays at that url, but it looks like the css isn't applying, the osticket logo is an x, font's look a bit off etc. and as described in my first post, the first few links go back to the http://servername rather than http://servername/support.


    I've since tried a reinstall and from the outset it looks like something is not right:
    if i type in http://servername/support, it redirects to http://servername/setup - i think it should be be 
    http://servername/support/setup.  

    If i just go to http://servername/support when installing i just get a "page cannot be displayed" message in my browser. 

    As mentioned, i am using IIS should that make any difference to anything.
  • @GeertCF please start your own thread.

    @kr55 I haven't installed 1.9.3 yet, I had one issue with this on 1.6 up through 1.9.2 under IIS.  I actually had to edit the bootstrap to change the path.  My understanding is that was fixed in newer versions though.  There have been a smattering of individuals who posted having some IIS issues where they needed to remove the included web,config file.  You might want to try that.  I presumed that it was something about their config.
  • Firstly, thanks for replying!  

    I did try deleting the webconfig file, but that didn't affect anything - I assume you meant deleting whilst OST is installed and not delete it before installation?      

    I'm not very familiar with the bootstrap file, so i'm not too sure what to change there.  I assume there's something up with the root directory setting somewhere.

    ** I've now reinstalled by placing all of the setup files in the server root directory, so that would be in the inetpub/wwwroot folder on my test machine and the installation worked fine (just by going to http://servername) and my "directory issue" is no longer there - it all looks good now.  **


    However, I'd still like to install it in a virtual directory though!  I'm assuming other people have installed v193 in webserver subdirectories without a problem otherwise i'd see more posts in the forum.  

    Does this sound like an installation bug or something IIS related?  Has anyone got v193 working in IIS (6) under a virtual directory? 

Sign In or Register to comment.