Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion

osTicket v1.10 (stable) and Maintenance Release v1.9.15 are now available! Go get it now

[resolved] New email address can't collect messages for a new department

Hello,

I have recently been asked to work on an existing osticket installation:

osticket 1.7.1
CentOS 6.2
php 5.3.10

The email address is hosted on exchange (Windows Server 2003).

We currently have a working Department and ticket queue, this collects email from support@. (the cron job is set up on the server in /etc/cron)

When I set up the new department and queue I had a few errors, but now osticket doesn't give any errors on the new email address opsqueue@. I can log in to the mailbox via IMAP (or OWA) and see the email (marked as unread) in the mailbox.

However, osticket is not pulling the new email in to the new queue I have set up. Both the new department and new email address are set up in the same way as the working ones.

I have checked in /var/log/httpd/support_error_log (that seems to be where all the error logging is going for osticket), if I enter incorrect information for the email address I see errors, but if I have everything correct, I see no errors, however the mail is still not collected.

Has anyone any suggestions on how to fix this issue? Is there a problem with collecting from multiple IMAP mailboxes? (I did try setting my new address to POP3 temporarily but had no joy, configuration was fine and worked, but wouldn't collect still)

I can look at upgrading to the latest 1.7 branch version tomorrow, but I'm worried that won't fix it.

Thanks for any help 
Tagged:

Comments

  • You might want to check your mail server to see whats in the logs for the user that your trying to check email with. At this point 1.7 is pretty old... so you probably should consider upgrading.  I do not recall any issues with checking mail in multiple mail boxes but its been quite a while since I used 1.7.x
  • Thanks for your response, I turned IMAP logging on in Exchange, I then went to the email in osticket and confirmed the settings just to check something was logged, at this point I saw the opsqueue@ email account getting logged in, although it didn't download any mail.

    Then I left it for 10 minutes and checked the logs again, while I could see the other mail queue being logged in to, searching for opsqueue@ finds no results after the first login when I was testing that it was logging.

    So from the looks of it it's not attempting to log in to the second mail queue we have set up?

    I'll look at updating to the newest 1.7.x version shortly to see if that fixes it.
  • I updated the installation to 1.7.10 and the new queue started working immediately. I guess t must have been a bug in the old version we were running. Thanks for the help anyway.
  • Right on, and your very welcome. :)  I'll mark this as resolved and close the thread.

    Please feel free to start a new thread if you have another question, comment, etc.
This discussion has been closed.