Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion

osTicket v1.10 (stable) and Maintenance Release v1.9.15 are now available! Go get it now

Cron mail fetching - memory allocation issue with cron

Dear community,

need support with following issue: after three months of proper operating, cron job stopped working and started sending me error reports with following content:
PHP Warning:  imap_open(): Couldn't open stream {imap.gmail.com:993/imap/ssl/novalidate-cert}INBOX in /hosting/b10-22***/data/www/web-site-name/support/include/class.mailfetch.php on line 141
PHP Fatal error:  Allowed memory size of 134217728 bytes exhausted (tried to allocate 76 bytes) in /hosting/b10-22***/data/www/web-site-name/support/include/class.osticket.php on line 280

Meantime web-sites in my account continue to work properly.
Currently I'm dealing with hoster support on this issue already for 10 deys and do not see any progress in solving the issue from hoster (as expected - they told me that issue with my script)

Is there any ideas and suggestions how to fix issue? Or it is definitely on hoster side?
Thanks in advance!

==================
osTiket infro:
osTicket Versionv1.9.3 (bba9ccc)
Server SoftwareApache
PHP Version5.3.14
MySQL Version5.5.25

PHP Settings
cgi.fix_pathinfo = 1"1" is recommended if AJAX is not working

All PHP extensions are available.

P.S. As workaround I tried to start using remote cron, but there are another story... )
Tagged:

Comments

  • Since I have no idea what could be the cause of your issue, I just asked some search engines. You may have a look at the following discussion with a similar problem:

  • Re: PHP Warning:  imap_open(): Couldn't open stream {imap.gmail.com:993/imap/ssl/novalidate-cert}INBOX in /hosting/b10-22***/data/www/web-site-name/support/include/class.mailfetch.php on line 141

    Sounds like your not connecting to gmail (Couldn't open stream).  Firewall?

    Re: PHP Fatal error:  Allowed memory size of 134217728 bytes exhausted (tried to allocate 76 bytes) in /hosting/b10-22***/data/www/web-site-name/support/include/class.osticket.php on line 280

    Sounds like you edit php.ini increase the amount of memory available to PHP.

    maybe like:
    memory_limit = 256M

    Generally php.ini changes require a webserver restart.

  • Guys,

    thank you for your involvement - the issue was solved by changing the hosting provider. )

    After several days of wasting time on mailing with their support - I just moved to another hosting and everything started working fine! So, I think the old hosting provider made some wrong changes to global config on the server - and it was the root case.

    Thanks again for your comments! )
Sign In or Register to comment.