Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion

osTicket v1.10 (stable) and Maintenance Release v1.9.15 are now available! Go get it now

After upgrade 1.6 to 1.9 - Attachments cannot be displayed because contain errors

Hi,

I generally try and self help myself with issues like these but have exhausted google and spent the last day trying to solve this issue so thought i would reach out to some experts for ideas!

I have been using v1.6rc4 for the last 4 maybe 5 years - love it, works great, applied some mods - did everything it was supposed to. But was ageing, so decided to update.

I updated as follows:
1.6RC4 to 1.6ST
1.6ST to 1.7
1.7 to 1.7.10
1.7.10 to 1.8.5
1.8.5 to 1.9.3

I was amazed at how well this worked, literally everything seemed to come across and work as expected on the test upgrade, so i did it again for real on the production system and, again, worked great.

Only issue is attachments! They just don't seem to work, they upload ok, seem to be stored in the database ok, but when trying to view firefox gives the error "The image XXXXX cannot be displayed because it contains errors". Chrome and IE just show as a broken link.
image

What i've tried - 
Installing the plugin for storing attachments in the file system - same error (however can see the files on the server via FTP and look ok, so not a permissions issue).

Upgrading to 1.9.4-rc5 - no different

Doing a fresh/blank install on the same server - works perfectly? So must be something from the upgrade

Dropping the tables - ost_attachment, ost_file, ost_file_chunk & ost_ticket_attachment from the database, and replacing them with the new ones from my fresh install - no difference.

I am not worried about losing all my previous attachments, I just want it to work for any new attachments. (I don't want to lose ticket history though)

Below are the details about my installation. Hopefully i've covered everything. Sorry if i've missed anything - i rarely post on forums as usually find my answers without posting - so go easy on me!

image

Comments

  • This is probably a silly question.  But have you tried clearing your browser cache?
    People have reported some really wonky behavior after performing an upgrade if they don't.
    It's entirely possible that you have discovered a bug that was introduced at some point around... 1.7.1ish.
  • Not a silly question at all, i actually hadn't tried that. However just tried it and no joy, same result. Really a strange one.
  • One more question... ad Admin panel -> Settings -> Tickets
    do you have Enable HTML Ticket Thread checked?

Sign In or Register to comment.