Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion

osTicket v1.10 (stable) and Maintenance Release v1.9.15 are now available! Go get it now

Client does not have permissions to send as this sender.

I Keep getting an error every time I test the ticket system.

Failed to send data [SMTP: Invalid response code received from server (code: 550, response: 5.7.1 Client does not have permissions to send as this sender)]

I am completely baffled. Anyone have a clue as to what could be my problem?

(v1.6 ST)

Comments

  • (this is going to sound vague) It sounds like your authenticating as a user [test001], and then trying to send email as a different user[test002]. Can you give us a little more information about your setup?

    (server os, mail server software and version, etc)
  • edited October 2013
    Message "Failed to send data [SMTP: Invalid response code received from server (code: 550, response: 5.7.1 Client does not have permissions to send as this sender)]" is delivered by Microsoft Exchange server

    Sending E-Mails is configured to use the SMTP Server of our Exchange Server. By Default, an authorized user [test001] Can send mails with Sender email address of [test001], but is not authorized to send e-mails using the email address of another user [test002]. In our case, user [test001] is the Service account of osTicket, user [test002] is the account of a real user.

    In Exchange Server, I could add authorization in user object [test002], that [test001] is allowed to send emails in his Name; but if I have to do it for each user account in the whole Company, it is a Horror. I haven't seen any possibility in Exchange to configure user [test001] (the Service account of osTicket) to be authorized to send emails in the Name of Group of other users :-(

    So, is there a configuration possibility somewhere in Settings or code to deactive the sending of E-Mails in the Name of other users? (The reply-to address usually can be set to user [test002] without any Problems.)

    BTW: I'm using osTicket v1.7.2 with outgoing email Setup with phpFunction
This discussion has been closed.