Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion

osTicket v1.10 (stable) and Maintenance Release v1.9.15 are now available! Go get it now

[resolved] Access Denied problem

I am moving an osTicket install from a hacked server to a new server. It is version 1.9.2.

I moved everything over and now I get "Access Denied" when I try to login and "Unable to verify username [username]" when I try forgotten password.

I tried a few things and then decided to re-install 1.9.2 from scratch (so that it would be database compatible). The install went fine (except it thinks I need the php IMAP extension, which is already installed) but I still have a similar problem.
Now when I login (with the newly created administrator created database) it appears to work, but I end up at the home page and still have the sign in link. If I try to login again I get access denied and if I try to reset my password I get the unable to verify username error.

Looking in the database, I see that sessions are created, but the user_id is always 0. Any suggestions on what to do next? Is the latest version database compatible?


Tagged:

Comments

  • What exactly did you do when you moved to the new server?

    Just curious since I would recommend to do it this way:
    - Do a dump of the database at the old server
    - Pack (tar, zip, whatever) the osTicket installation directory at the old server
    - Re-Create the database and the user permissions at the new server
    - Import the dump into the new server mysql database
    - Unpack the osTicket installation directory

    Now, I think, everything SHOULD be the same and work like before. Beside that, I would make sure to install the same versions of PHP, mysql, etc. at the new server to make sure that really nothing changed (beside the server itself)

    The database structure of the latest version is btw. not compatible with 1.9.2 since with 1.9.4. there have been some changes in the database. Alternatively you can try to upgrade your instance at the old server to 1.9.4 before you move it to the new server - but make a backup first! ;)

    One last question: Do you see any errors in the logs?
  • The steps you describe are basically what I did.

    Things did change for sure, the old server was Ubuntu 12, the new is Ubuntu 14 (and I don't have control over that)

    Unfortunately the old server is all but unusable with a file system forced to readonly, so I can't upgrade it

    I am pretty sure there's just a missing configuration or permission because as I say I tried an install from scratch and have pretty much the same problem.

    I couldn't see any errors in the logs (looking in the mysql and apache2 errors - any others I should check?)
  • So you:
    A. moved your old files/database to the new server: and cannot log in.
    B. setup a completely new files/database on the new server: and cannot log in.

    Have you tried recovering the admin password?
    http://www.tmib.net/content/recover-reset-admin-account-passowrd-osticket
    note: article is a little old, but still works.

  • I have not tried recovering the admin password, but from what I can see in the database, the password is no longer saved as an md5 hash.

    That all said, the forgotten password function says it's unable to verify the username, so I don't think the issue is password related, I think there's a deeper database related problem
  • osTicket can read a md5 hash for password recovery purposes.  Please give it a try and see what happens.
  • I just tried it, still the same problem.
  • Sorted. As you would expect, it's user error!

    Note: I've never used osTicket before. The users of the system told me it was working before, and gave me their login so I could check it was working on the new server.

    What I found out is that you don't sign in on the sign in page. You have to further click on the "I'm an agent". Now that I understand this, it all works fine.

    This misunderstanding was further compounded by the user showing me the login error on the user login page. I have no idea how he had it working on the last server!!

    Thanks for the suggestions on how to debug it!
  • Great you found the solution. I gonna close this discussion and mark it as resolved. If you any further questions or need help with something else regarding osTicket, please feel free to open a new discussion.
  • As a side note:

    Agents can go directly to YOURSITE.TLD/scp/ and they will be prompted to log in.
This discussion has been closed.