Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion

osTicket v1.10 (stable) and Maintenance Release v1.9.15 are now available! Go get it now

[resolved] Failed to connect to X.X.X.X:587 [SMTP: Failed to connect socket: Permission denied

HI,

when i configure the internal mail in osticket on Cent OS 6.4 i am getting this error can you please help me for this.

Failed to connect to XXX.XXX.XXX.XXX:587 [SMTP: Failed to connect socket: Permission denied (code: -1, response: )]


Tagged:

Comments

  • Please run "sestatus" and post the output here.

    Jack
  • edited January 2015
    The hint here is the: Permission denied
    Either your CentOS (SELinux) is prohibiting the connection, or the remote machine is rejecting it.  Either way this seems like a server config issue and not an osTicket one.

    Please help us to help you by reading and following the posting guidelines located in this thread: Please read before requesting assistance.  The more information you give us the better we will be able to assist you. Thank you.
  • I have run this "sestaus"

    and here is the outputs


    SELinux status:                 enabled
    SELinuxfs mount:                /selinux
    Current mode:                   enforcing
    Mode from config file:          enforcing
    Policy version:                 24
    Policy from config file:        targeted

  • Does this host require SELinux? If not, I'd disable it.

    Please be sure to respond to ntozier's request--read
    and reply with the requested info.

    Jack
  • Thanks guys,


    My issue is fixed now. thanks for your help.
  • What was the fix?

    Jack
  • i have disabled the SELinux then its start working without any issue


    Thanks guys for your help and support.


    Nitesh
  • Thanks for sharing the solution with us. I close this thread and mark it as resolved.

    Feel free to open a new discussion.
This discussion has been closed.