Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion

osTicket v1.10 (stable) and Maintenance Release v1.9.15 are now available! Go get it now

1.7 Upgrade

Good Afternoon!
I hate to say this, but my upgrade to 1.7 was a disaster.

First, I'll be man enough to say that I depended on my servers backups instead of creating one on my own. Huge mistake. In the past, my host (OneWorldHosting) has maintained backups in increments, and per their own website kept backups DAILY, which would have been perfect. But they don't and they didn't and I screwed myself as a result. FAIR WARNING TO US ALL, I guess.

HOWEVER - The 1.7 installation did not do a check on the db to see if it was clean or if it contained populated tables. This should be a required check so that the install and upgrade scripts can treat a db appropriately. I'd also like to point out that the upgrade.php resides in /scp and install.php resides in /setup, which I feel is a flaw that needs to be addressed.

Installation files should all reside in the same directory, and the setup process should include a way to interact with the db and installer to see if the setup is indeed an upgrade or a fresh installation. The upgrade.txt file in the root did not mention an upgrade.php file. I only found it after looking through the directory to see if there was something that I missed...

I guess that's why we're still in RC3 state.

Comments

  • RC4 - Not any better

    So this morning, being that its the end of the world and all... I decided to take a peek and get moving up to RC4 before we call this thing stable. I have uploaded the files to the host, and attempted to run the upgrade.

    On the plus side - The system gives me plenty of notice that the upgrade it there and that it needs to run. It has its own little process ready for me and all I have to do is a couple clicks, and it will work everything out all on its own.

    But... it doesn't. A pop-up box appears just long enough for me to see Smile! and then disappears... but nothing has changed, and the only page I can go to is... this one.

    URGH.
  • Sorry to hear that you lost your data. I would like to state for the record that 1.7 is not a final or stable release, and should not be used in a production environment until 1.7ST is released.
  • Understood...

    But the upgrade path is BROKEN, period. Regardless of the data, even the upgrade to RC4 does not work.

    As of this morning I have attempted to create a new db under the RC4 installer, and that worked out (because it's really just a new "installation") but there is no way to replace the data from the backup of the actual database, without error... these types of things are not RC level changes.. they are alpha level changes, and beta at worst. To change the db structure on the last RC is just an example of poor change control.
  • @Troy14 - The issues you're having are caused by failed AJAX calls - due to restrictive apache settings (i.e disabled MultiViews option). We're working on a workaround on how osTicket makes ajax calls.

    Data Loss
    We've made the installer more foolproof to avoid possible database overwrite - table prefix must now be unique. But I must add that you probably didn't glance at the upgrade instructions for v1.7 at all - overwrote config file manually then went ahead and completed installation form.

    Upgrader got moved to /scp because osTicket now support continuous upgrade (see below).

    Upgrader and DB changes
    One of the great features we added to v1.7 is support for continuous upgrade (think monkey patching). DB changes can be made at any point. This allows users to install and upgrade from github (develop or any feature branch at any point of development). In addition, it allows developers to make DB related changes at a feature branch level.

    In other words - making DB changes is no longer a bottleneck in development process. Not sure if you're a developer of not - but if you've ever used git at all then you'll understand why it's a great future as opposed to "poor change control".
  • troy14,

    Over the weekend, I setup and installed a fresh v1.6ST, and created a couple tickets (including one with an attachment). I then upgraded to v1.7rc4, and did not encounter the problem that you have reported. I was hoping to be able to give you some feedback on why you might have experienced this, but wasn't able to.

    When you installed did you run the installer or the upgrader? They look completely different. The Upgrader looks like this:

    http://tmib.net/files/articles/osticket-upgrade-1.7rc/1.6-to-1.7rc4_1-small.png

    The installer looks like this:

    http://tmib.net/files/articles/osticket-upgrade-1.7rc/installer-1.7rc4.png

    note: I am running OST under IIS not Apache.
  • @ntozier - I'm 100% sure the issue is related to failed AJAX calls. A quick scan of apache logs should confirm it.
  • I ran the upgrader... I uploaded the files and when I went to /scp I was prompted for the upgrade... and I have no choice to do anythin else...

    Thanks!
  • Upgrade failed again...

    Again, today I tried with the upgrade to RC5... Failure. It does the same thing that the upgrade to RC4 did, and that was to just stall with the upgrade process was started. Now, I'm stuck in that same loop and the installation has become unusable.
  • I think the failed AJAX calls may have been an issue for some but that was not my experience. I saw the thread on github about the upgrader not working and I called the host to check out my install to see if there should be a conflict, and I should not be having these issues.

    I am using a LAMP install on a shared webhost, so is it possible we need to consider other solutions?
  • problem on OSX with upgrade

    HI,

    i decided to try the new version, so (after a backup) i copied the files into
    /Library/WebServer/Documents and went to help desk/scp/admin.php
    which is what i thought i was supposed to do

    i was prompted with the installer, not an upgrade. so anyway, i had green ticks so i went through renaming the config, and then it made me choose a new table prefix, i did that and ended up with a brand new install.

    of course, i reinstalled and now have a working version of 1.6. but how do i get to the upgrade?? i tried to run /scp/upgrade.php but it seems to redirect to /setup/install.php,

    any help would be appreciated, id rather not start from scratch if i can help it.


    Regards,


    Russ
  • It doesn't sound like you downloaded the version from:

    https://github.com/osTicket/osTicket-1.7/archive/v1.7-RC6.zip
  • i downloaded that version and its the same result, i'm fairly sure thats what i downloaded first time i tried.

    what should i check for you to see why it fails to run the upgrade?


    Regards,


    Russ
Sign In or Register to comment.