Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion

osTicket v1.10 (stable) and Maintenance Release v1.9.15 are now available! Go get it now

Client won't get email after creating a ticket

Good evening,

we're currently using OSTicket version 1.6 for internal and external troubleshooting.
Our problem is: if clients create new tickets via the web interface no confirmation email is sent out. The only thing they get is the "ticket created" screen and that's it.
They do get confirmation emails if we create tickets in the SCP.
I enabled every function in the autoresponder settings and tried several different email addresses on the web interface but it just won't work.

Tagged:

Comments

  • edited February 2015
    You're using 1.6, so you must have been using this for quite a while.  Did this suddenly stop working?

    Is there any reason not to use the current version (1.9.5.1)?

    Jack
  • osTicket version 1.6. is ancient and not support anymore, so instead of trying to troubleshoot the error, I would recommend to make a backup and upgrade to the current latest version (1.9.5.1 as of now).
  • It just came to our attention today. Normally we instantly respond to our clients, so i don't know if it was working before or not.

    We've already tried to upgrade to the latest version of OSTicket but that won't work. I've also tried to make a backup and then clean the already installed version and install the latest version but that also won't work.
    Using the latest version is pretty much not an option at this point. 
     
  • Version 1.6 is not supported, as @Chefkeks said.

    But we can try.  First, we need you to tell us about your system. We don't yet even know what OS it is on, or what web server it's using.  There should be log files that can answer your questions, but without more info, we can't guess where they are. Start here:

    Jack  
  • It's running on a virtual Win 7 Pro machine.
    As to the logs: i will try to go through them later today and try to post as much as possible. 
  • It's running on a virtual Win 7 Pro machine. 
    That's only a small part of the info requested. Hopefully, the logs will answer your questions.

    If you still need our help, please respond as requested in the post:

    Jack
     
  • PHP version is 5.4.7.
    As i said yesterday it's running on a virtual 7 Pro machine on Xampp.
    These are the error logs (PHP and Apache at the end) i get as soon as a client creates a new ticket on the web interface.

    The only thing different from the stock version of OSTicket is the German translation pack. I've already tried turning it back to English to see if creating a new ticket works, but it didn't. 
  • We got what you said yesterday.  Repeating it is not necessary. You have not told us what php version you have, and what php extensions. We don't know if you're using SMTP or the php mail function.  And rather than posting the requested log info, you redirect us to another site.

    I was willing to try, but I don't have time to chase down the information needed.

    I recommend updating to the current version, and then come back here if you can't make it work.

    Jack
  • The only thing different from the stock version of OSTicket is the German translation pack. I've already tried turning it back to English to see if creating a new ticket works, but it didn't. 
    There was no official osTicket German translation pack back at 1.6.x - so I doubt you're the official osTicket 1.6.x and instead use a customized version from where-ever. And trust me, as German translator and proofreader I know that pretty good and 100% sure that there was no language pack for 1.6.x ;)

    Just out of curiosity (if you still know):
    Where did you download your 1.6.x version back at the days when you set it up?
Sign In or Register to comment.