Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion

osTicket v1.10 (stable) and Maintenance Release v1.9.15 are now available! Go get it now

AD integration is not running - config can not be stored - white page

hey guys,

I have the osTicket now being updated to 1.9.7 and now try the Active Directory integration set.

I can install the plugin, the problem is that I'm just a white page when i say save.

I have this workaround to implement already tried, but without success.

http://osticket.com/forum/discussion/77619/ldap-and-active-directory-plugin-missing-ldap2-php

am I doing
something wrong?
Has someone a tip for me.


sorry for my bad english

and many thanks in advance

Tagged:

Comments

  • Update:

    PHP Error Log

    [12-May-2015 09:40:02 Europe/Berlin] PHP Fatal error:  Cannot redeclare class Net_LDAP2 in D:\xampp\htdocs\OSTicket\include\Net\LDAP2.php on line 1766
  • From where did you download the ldap plugin? (osticket.com/download is recommended)
  • hi

    the sources

    https://github.com/osTicket/core-plugins
    and
    osticket.com/download

    Neither works
  • Both with the same error in your log?

    Asking since the github version does NOT include NET_LDAP2 (as far as I remember correctly) but runs without phar extension and the one from osTicket.com/download does include NET_LDAP2, but does also need the phar extension of php.
  • Yes, the problem is always the same in php log.

    I have the whole lot again Erased and only the phar of osTicket installed, but since I have the same problem, with the white page

    [18-May-2015 09:27:28 Europe/Berlin] PHP Fatal error:  Cannot redeclare class Net_LDAP2 in D:\xampp\htdocs\OSTicket\include\Net\LDAP2.php on line 1766




  • Unbenannt2.png
    953 x 777 - 84K
  • Update: the same problem with version 1.9.8.1
  • edited May 2015
    No idea what this could be - maybe @ntozier has?
    And maybe your osTicket system info helps here, so can you provide them? (Admin panel > dashboard > information)
  • Silly question... but when you upgraded osTicket... did you re-download the ldap plugin from osticket.com/downloads ?
  • edited May 2015
    Hey everyone,

    I have now made a new backup from the old system and again run the updatet to 1.9.8.1. I have downloaded and installed from the osTicket plugin, this time I was able to set up and save it.

    Now a new problem, I can not activate the plugin, it will simply be deactivated.


    About this osTicket Installation


    Server Information
    osTicket Versionv1.9.8.1 (4752178)
    Web Server SoftwareApache/2.4.9 (Win32) OpenSSL/1.0.1g PHP/5.5.11
    MySQL Version5.6.16
    PHP Version5.5.11
    PHP Extensions
    gdlib Used for image manipulation and PDF printing
    imap Used for email fetching
    xml XML API
    xml-dom Used for HTML email processing
    json Improves performance creating and processing JSON
    mbstring Highly recommended for non western european language content
    phar Highly recommended for plugins and language packs
    fileinfo Used to detect file types for uploads
    PHP Settings
    cgi.fix_pathinfo "1" is recommended if AJAX is not working
    date.timezone Europe/Berlin
    Database Information and Usage
    SchemaosTicket (localhost)
    Schema Signatureb26f29a6bb5dbb3510b057632182d138
    Space Used60.16 MiB
    Space for Attachments165.02 MiB

    Installed Language Packs

    Deutsch (German) — de_DE  

    Version: 143155, Built: Wed, 13 May 15 16:35:03 -0500
  • Sorry but I have not upgraded to v1.9.8.1 yet so I can't really troubleshoot this.
    Are you seeing any errors in the PHP error log?
    Or maybe in the osTicket log?
    How about in the event log on your AD server?
  • In addition to ntoziers response: What happens when you set it active / enabling it via the database directly, so changing the is_active flag from 0 to 1?
  • @ ntozier

    in the logs (AD / osTicket / OS server / PHP) is nothing to find.

    @ Chefkeks

    it worked perfectly, the plugin is enabled and after I have entered my AD name, I could account Login with.

    I will now test all :-) Thank you so much


    **************************

    ps If I want regestrieren a guest, I get this error, I should make the time to debug?
    I can not open and edit the templates, open up not only in the Verson 1.9.7 I could.


    Error: Project-Id-Version: osticket-officialPOT-Create-Date: 2015-04-02 10:00 -0500Report-Msgid-Bugs-To: support@osticket.comLanguage: de_DEMIME-Version: 1.0Content-Type: text/plain; charset=UTF-8Content-Transfer-Encoding: 8bitX-Generator: crowdin.comP...
Sign In or Register to comment.