Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion

osTicket v1.10 (stable) and Maintenance Release v1.9.15 are now available! Go get it now

Error while installing osticket 1.7.14

Hi,

While setting up Osticket v1.7.14, it shows the osTicket Basic Installation page. After filling up the details and clicking Install Now button I get the message Doing Stuff.. Please Wait. After couple of seconds I get a blank page, when I check the phpmyadmin the tables have been populated but when I try to open the admin page or the user page it redirects back to setup page. Kindly let me know if there is a issue with the code or something else because I have tried it on couple systems one with OS Windows 8 and other with OS Windows 7 it is the same issue.

WAMPServer version: 2.5
Apache Version: 2.4.9
PHP Version: 5.5.12
MySQL Version: 5.6.17

Kindly let me know if any more information is required. I have not done any code modifications. This issue is for a freshly downloaded files as well.

Below are the errors found in php error log:
[12-May-2015 16:32:58 UTC] PHP Fatal error:  Class 'Crypto' not found in E:\wamp\www\support\include\class.misc.php on line 29
[12-May-2015 16:32:58 UTC] PHP Stack trace:
[12-May-2015 16:32:58 UTC] PHP   1. {main}() E:\wamp\www\support\setup\install.php:0
[12-May-2015 16:32:58 UTC] PHP   2. Installer->install() E:\wamp\www\support\setup\install.php:52
[12-May-2015 16:32:58 UTC] PHP   3. Misc->randCode() E:\wamp\www\support\setup\inc\class.installer.php:229
[12-May-2015 16:40:37 UTC] PHP Fatal error:  Class 'Crypto' not found in E:\wamp\www\support\include\class.misc.php on line 29
[12-May-2015 16:40:37 UTC] PHP Stack trace:
[12-May-2015 16:40:37 UTC] PHP   1. {main}() E:\wamp\www\support\setup\install.php:0
[12-May-2015 16:40:37 UTC] PHP   2. Installer->install() E:\wamp\www\support\setup\install.php:52
[12-May-2015 16:40:37 UTC] PHP   3. Misc->randCode() E:\wamp\www\support\setup\inc\class.installer.php:229

Regards,
Vipin
Tagged:

Comments

  • Hi,

    The same is the issue with osticket version 1.7.13. But when I installed version 1.7.12, I did not get any errors and it installed successfully. I guess the issue is with the code itself.

    Regards
    Vipin
  • Beside the fact that you managed your issue with a different version, is there any reason why you install such an old version of osTicket?

    Current version is 1.9.7 and you can get it (as always) from the official download page: osticket.com/download
Sign In or Register to comment.