Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion

osTicket v1.10 (stable) and Maintenance Release v1.9.15 are now available! Go get it now

mail content encoding problem

Hi,

When I try use plain text autoresponder mail, then my client get unreadable message with wrong encoding.
I notice problem only with mail content. title is encoded correctly.

What can I change to improve this?

Below information about mine system:
Server Information
osTicket Versionv1.9.8.1 (4752178)
Web Server SoftwareApache
MySQL Version5.6.22
PHP Version5.3.28-0+tld2
Tagged:

Comments

  • Can you post a screenshot?

    Additionally can you try different email clients / name the email client software that your client is using?
  • In attachments I put 2 screenshot.
    1st shows gmail inbox, You can see there correctly encoded mail title, but problem with content
    2nd shows wrong encoding mail content.

    What more do you need to diagnose the problem?

    mail income.png
    1920 x 1200 - 591K
    mail content.png
    1917 x 1200 - 199K
  • Seems to me like a Gmail related issue. Just take a look at the following:

    On the second page, take a special look at the bottom:

    Work around for UNreadable e-mails:

    • Open the e-mail on Gmail page

    • Find the 'additional options' arrow in the top right corner of the mail's frame (next to word 'Reply')

    • click on it and choose there "Message text garbled?"

    • Then on that special view page you can choose encoding in the menu of your browser to make the text readable, for example, in Internet Explorer try View/Encoding/"Cyrillic(Windows)" and this does not help then try KOI8-R encoding. That is, try different ones until you see readable text.
  • edited June 2015

    I`ll use all encoding, but none of them is correct..
    Below I paste mine garbled message:

    From: removed :)

    To:  
    Date: Mon, 1 Jun 2015 20:44:12 +0200 
    Subject: [#000243] ĄŚĆŻŹŁŃÓęąśćżźłńóę 
     
    *Witamy serdecznie,*
    --------------------
    niniejsza wiadomość została wygenerowana automatycznie i stanowi potwierdzenie
    rejestracji Państwa zgłoszenia pod numerem [#000243] w systemie BOK stabilny.net
    
    Poniżej załączamy treść oryginalnej wiadomości: 
    
    > ĄŚĆŻŹŁŃÓęąśćżźłńóę
    > 
    > polish font problem
    
    W przypadku jakichkolwiek pytań pozostajemy do dyspozycji.
    
    Pozdrawiamy,
    Biuro Obsługi Klienta
    
    Pamiętasz jak skończył Titanic?
    Ref-Mid: $SwIAAA==$5d66a511c0@ed124d096f

    As seen above, all polish character is wrong encoded.
    ĄŚĆŻŹŁŃÓęąśćżźłńóę - this is correct encoded title
    ĄŚĆŻŹŁŃÓęąśćżźłńóę - this is the same text in content, wrong encoded.
    I think it is not gmail problem, but sth with osticket encoding mail content.

  • Sounds like you're pretty sure it's not related to Gmail, so I advise you to open an issue over at github:

    The developers can then respond to you there and keep track of the issue.


    Additionally: @ntozier Can you include this in your (daily) report to the devs? Thanks ;)
  • I've pinged them about this thread.
  • Could you maybe try the fix posted here? I think it might be the html2text engine that is processing your text incorrectly.
Sign In or Register to comment.