Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion

osTicket v1.10 (stable) and Maintenance Release v1.9.15 are now available! Go get it now

Upgrade from 1.9.4 => 1.9.8.1

Hi all,

For a few months I have been running osTicket 1.9.4 quite happily. I just noticed that a since I installed the current setup a few updates have been published. 
Since I have been experiencing issues with users opening tickets using Yahoo email addresses, I hope upgrading might resolve this (Tickets opened by Yahoo email addresses get opened ok, but if a user replies to an existing ticket, instead of appending, a new ticket is always opened.).

I followed the instruction from the wiki on a test setup where I made a duplicate of the files and database. As far as I can tell all went ok. 

I read the part about the upgrade script: 
To run the upgrade script, simply login to admin panel of your osTicket helpdesk. The upgrader is now a primary component of the osTicket, so upgrades are triggered automatically anytime you upload a new version which requires a database migration.

Is it correct that no database migration has to be executed when upgrading from 1.9.4 => 1.9.8.1? I was not shown the upgrade wizard after first login to the updated system. The admin panel just showed that the current version was 1.9.8.1. Is this how it supposed to be or may I have missed a step?

Also I use the Oauth2 plugin to login using google+. Will the plugin work after the upgrade, or do I need to take additional steps to make sure the Oauth2 plugin keep functioning?

Any feedback is much appreciated.

Comments

  • Q: Is it correct that no database migration has to be executed when upgrading from 1.9.4 => 1.9.8.1?
    A: Yes that is correct.

    Q: do I need to take additional steps to make sure the Oauth2 plugin keep functioning?
    A: As far as I know the only thing necessary would be to download the update for the oauth plugin as well. When there is no update for the oauth plugin, there is no need to do anything.
    That said a little additional note: Since we personally never used the oauth plugin I don't how it works but since we use http auth and ldap auth I guess it's the same procedure - update osTicket, update the plugin (when there is a update too)

    Cheers,
    Michael
  • Thanks Michael, exactly what I needed to know. I'll do the upgrade and will post here if I'll experience any issues with oauth (or if it works just fine without upgrading)
  • For any future readers. OAUTH works flawlessly with 1.9.8.1 also the Yahoo mail issue I mentioned seems resolved, nice!
Sign In or Register to comment.