Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion

osTicket v1.10 (stable) and Maintenance Release v1.9.15 are now available! Go get it now

Updating Company Info Under Admin > Settings > Company displays client home page and results in 403

Hello,

I've searched with both Google and within the search tool here and have not found anything that is on point. Please accept my apologies if there is something I overlooked.

Per your guidelines, here is my information. Note I am on a shared hosting environment and therefore do not control the server and as such will not be able to get much server information other than what is visible through cpanel.

osTicket Version v1.9.9-1-gbe2f138 (be2f138)
Web Server Software Apache
MySQL Version 5.5.42
PHP Version 5.4.42


I've recently upgraded from 1.6 something (I think - didn't think to look before upgrading).

The Issue:

When I attempt to update the information in the Admin > Settings > Company section, it doesn't take. The URL stays the same but it displays the client's home page (the page to submit a ticket or check ticket status) and a 403 Forbidden is thrown (I can see this in Firebug's Console)

Some things I've tested:

I am able to reply to a ticket (another thread I saw).
I am able to change settings on the Admin > Settings > System tab
I am able to create a ticket through the SCP interface
Email sweeping works

Taking a look at permissions it looks like all folders are set to 0755 and all files are set to 0644. Not sure if something needs to be changed after I uploaded the new files (I uploaded the new install over the top of the old having FileZilla overwrite existing files). I tried searching for update documentation and there doesn't appear to be any.

Please let me know what I am doing wrong. I appreciate the support. The product is greatly enhanced and I absolutely love the improvements that were made.
Tagged:

Comments

  • Please consult your Apache error log and see what additional information you can get about the 403 error.
    You may also want to consult your PHP error log also to see if there anything being logged to that.
  • I see these two entries...which confuses me. Two separate POST requests to settings.php, one was 200 OK and the other was 403 Forbidden

    2604:6000:1105:2009:c10e:81f5:a66b:e0f8 - - [07/Jul/2015:10:52:18 -0400] "POST /scp/settings.php?t=pages HTTP/1.1" 200 4011 "http://ticket.nysoma.org/scp/settings.php?t=pages" "Mozilla/5.0 (Windows NT 6.1; rv:38.0) Gecko/20100101 Firefox/38.0"
    2604:6000:1105:2009:c10e:81f5:a66b:e0f8 - - [07/Jul/2015:10:58:26 -0400] "POST /scp/settings.php?t=pages HTTP/1.1" 403 1504 "http://ticket.nysoma.org/scp/settings.php?t=pages" "Mozilla/5.0 (Windows NT 6.1; rv:38.0) Gecko/20100101 Firefox/38.0"

    I am assumimg the 200 OK was when I made a change to the System Settings. The 403 was when I made a change to the Company Settings. 

    The PHP error log I have access to doesn't show anything. The osTicket log also shows nothing.
  • I made an error...the version I was using was v1.7. I just tried updating another instance and get the same results. Its on the same shared hosting environment.


  • SOLVED - When you add the website address, you need to omit the http:// or it throws the 403. This is to do with mod_security in Apache. I found this article that led me to try it without the http:// in the Website field. http://edrackham.com/javascript/solution-to-form-submit-403-error/

    May want to include this in the docs.
Sign In or Register to comment.