Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion

osTicket v1.10 (stable) and Maintenance Release v1.9.15 are now available! Go get it now

Internet Explorer - Cannot open tickets and unable to save draft popup

I've recently installed the latest stable release(1.9.9) and it's working perfectly in Chrome and FF. However, in Internet Explorer 10 & 11(with and without compatibility mode) users are unable to open new tickets. The landing page works fine. Click "Open a New Ticket" and it takes you to the new ticket form but as soon as you click on "Create Ticket" it takes you back to the landing page. No thank you page is displayed and no ticket is created. It seems to be the same issue as described in this post(http://osticket.com/forum/discussion/76016/submitting-tickets-in-internet-explorer) but there is no resolution listed.

The second issue is the popup that reads "Unable to save draft..." as noted here: http://osticket.com/forum/discussion/76016/submitting-tickets-in-internet-explorer. The difference is that for me this is only happening in IE and NOT happening in Chrome or FF.

Any suggestions on how to remedy these issues? Thanks in advance!
Tagged:

Comments

  • Did you check your web server PHP error log?
    What PHP version are you running?
    What web server software after you using?
    What MySQL version?

    Please provide these info so we can better assist you. See also:
    http://osticket.com/forum/discussion/77766/please-read-before-requesting-assistance#latest
  • edited July 2015
    Nothing in the PHP error log.

    PHP: 5.4.7
    Apache(Win32): 2.4.3
    MySQL: 5.5.27

    Also, I pasted the wrong link in for the popup issue. Should be: https://github.com/osTicket/osTicket-1.8/issues/1189
  • Thanks for the correct link. It is mentioned that the issue with "draft saved" is fixed in 1.10 (currently developer preview version - comparable to a alpha or beta version).

    Regarding the issue that the end users can't submit a ticket in IE, I would enable the error level debug (default apache log level is usually warn/warning) and make sure that you try different IE versions or different systems and also that the cache of IE is cleared ;)

    Let me know how it's working out :)
  • I've set the LogLevel to error, tried it on multiple OSes: Win7, 8.1, Vista, cleaned cache on all of them before testing, and still nothing in the PHP or Apache logs after trying to submit a test ticket. 
  • Ok that's really weird. Do not have any new ideas currently what could be the issue / how to troubleshoot with an empty log. Maybe @ntozier has an idea?
  • Are you running 1.9.9 or 1.9.9-1?  If the former please upgrade and see if that helps.
  • It's actually 1.9.9-1. I attempted to upgrade to the 1.10 developer preview to see if that helped. That ended up being a bit of a disaster.
  • Update: Just upgraded to 1.9.11 and the problem still exists.

    Also, tried to upgrade to the 1.10rc1(from 1.9.11) and still having issues. These are the two errors that it emailed to me:

    [CREATE
    TABLE `ost_translation` ( `id` int(11) unsigned NOT NULL AUTO_INCREMENT,
    `object_hash` char(16) CHARACTER SET ascii DEFAULT NULL, `type`
    enum('phrase','article','override') DEFAULT NULL, `flags` int(10) unsigned NOT
    NULL DEFAULT '0', `revision` int(11) unsigned DEFAULT NULL, `agent_id` int(10)
    unsigned NOT NULL DEFAULT '0', `lang` varchar(16) NOT NULL DEFAULT '', `text`
    mediumtext NOT NULL, `source_text` text, `updated` timestamp NULL DEFAULT NULL
    ON UPDATE CURRENT_TIMESTAMP, PRIMARY KEY (`id`), KEY `type` (`type`,`lang`),
    KEY `object_hash` (`object_hash`) ) DEFAULT CHARSET=utf8] Table
    'ost_translation' already exists

    and

    [/**
    * @signature 1ee831c854fe9f35115a3e672916bb91 * @version v1.10.0 * @title Make
    editable content translatable and add queues * * This patch adds support for
    translatable administratively editable * content, such as help topic names,
    department and group names, site page * and faq content, etc. * * This patch
    also transitions from the timezone table to the Olson timezone * database
    available in PHP 5.3. */ ALTER TABLE `ost_attachment` ADD `lang` varchar(16)
    AFTER `inline`] Duplicate column name 'lang'

  • So your issue is that IE [10 and 11] doesn't let you open tickets.

    You have nothing in your error logs.
    So you upgraded and it still doesn't work and now you are running the beta and getting two errors. Right?

    The two errors there are:
    able 'ost_translation' already exists
    and
    Duplicate column name 'lang'.

    I'd restore [the site and database] from back up to 1.9.x.  1.10 isn't ready to be used in a production environment.  Then I would enable on screen error displays.
    http://www.tmib.net/osticket-v19x-frequently-asked-questions-faq#2

    Then I would try again and see if there are any errors displayed.
    If you want you can also PM @chefkeks or I your site url and we will try to replicate this and see if we see anything differently.

  • Hi All,

    Just I wanted commented out because I'm using 1.9.5 some times I'm getting above mentioned issue, when it occurs I just logged out and re-login to the system then its working fine but this is not happening time to time. I'm using Firefox 44.0.2 

    I've enabled the error log

    Invalid CSRF Token __CSRFToken__

    Invalid CSRF token [d76df0bdb8f470136e0cd7ad3d6b9cf94b29db0b] on http://helpdesk.cargillsceylon.com/support/scp/ajax.php/draft/9151

Sign In or Register to comment.