Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion

osTicket v1.10 (stable) and Maintenance Release v1.9.15 are now available! Go get it now

[resolved] Attachments on the filesystem

Hello, 

I installed plugin Attachment on the filesystem, everything I did according this discussion http://osticket.com/forum/discussion/86038/plugin-attachments/p1 
but plugin still not working. When I add attachment on my website, in attachments folder are keys and signature files like are in database. 
In ticket settings I have path to attachments folder and plugin is enable and in settings is folder with permission 777. 
Have anyone idea for solution this problem? 

My system: 
Server Information
osTicket Versionv1.9.9-1-gbe2f138 (be2f138)
Web Server SoftwareApache/2.2.15 (CentOS)
MySQL Version5.1.73
PHP Version5.3.3
Thank you so much.
Jakub

Comments

  • Also did you go to Admin panel -> Settings -> Tickets ->
    Attachments and change the back end to the filesystem in the drop down? 


    Did you enabled the plugin after installing and configuring it?
  • Yes, I changed path to filesystem folder in settings of tickets and i have enabled the plugin with all configuration. 
  • edited July 2015
    Hey together

    I test the plugin just for me, unfortunately, nothing is stored in the folder.

    plugin is active folder as having permissions

    someone falls or whatever somebody has an idea?


    Über diese osTicket-Installation

    Serverinformationen
    osTicket-Version     v1.9.11 (c1b5a33) — Up to date
    Server-Software     Apache/2.4.9 (Win32) mod_authnz_sspi/0.1.0 OpenSSL/1.0.1g PHP/5.5.11
    MySQL-Version     5.6.16
    PHP-Version     5.5.11
    PHP-Erweiterungen
    gdlib     Wird für die Bildmanipulation und PDF-Druck verwendet
    imap     Wird für den E-Mail-Abruf verwendet
    xml     XML API
    xml-dom     Wird für die HTML E-Mail-Verarbeitung verwendet
    json     Verbessert die Leistung beim Erzeugen und Verarbeiten von JSON
    mbstring     Dringend empfohlen für nicht-westeuropäische Sprachinhalte
    phar     Dringend empfohlen für Plug-ins und Sprachpakete
    fileinfo     Wird verwendet, um Dateitypen für Uploads zu erkennen
    PHP-Einstellungen
    cgi.fix_pathinfo     "1" wird empfohlen, wenn AJAX nicht funktioniert
    date.timezone     Europe/Berlin
    Datenbankinformationen und Nutzung
    Schema     osTicket (localhost)
    Schema-Signatur     b26f29a6bb5dbb3510b057632182d138
    Belegter Speicher gesamt     64.89 MiB
    Datenbankspeicher für Anhänge    
    image

    image
  • ok it works
    that would have times someone can write to :-)
    ....

    image
  • I have settings exactly how Oneil show in screenshots, but still it not working. 
  • iis or apache?
    all users has write access?
  • What you mean with apache? 
    I set only permission 777 for attachment folder
  • can you post screens from the os settings?
  • edited July 2015
    In attachments is my settings 

    Folder in my root osticket has name "attachment".
    ticket settings.png
    966 x 621 - 56K
    plugin.png
    952 x 160 - 14K
    manage plugin.png
    947 x 194 - 15K
    config.png
    633 x 464 - 37K
  • can you check the activation in the mysql database?
  • Everythink looks good. 

    Plugin Activation
    image

    Upload path in settings of plugin
    image

    Ticket settings 
    image
    2015-07-24_10h49_43.png
    986 x 51 - 14K
    2015-07-24_10h51_38.png
    860 x 23 - 7K
    2015-07-24_10h56_10.png
    863 x 53 - 16K
  • Any idea please? 
  • Are you running SELinux?  (since your on CentOS)
  • Yes, there is report from my CentOS VPS. 

    SELinux status:                 enabled
    SELinuxfs mount:                /selinux
    Current mode:                   permissive
    Mode from config file:          permissive
    Policy version:                 24
    Policy from config file:        targeted


  • What happens if you disable it?
  • still same problem with attachments. 
  • "When I add attachment on my website, in attachments folder are keys and signature files like are in database" This sounds to me like the plugin is working correct and the files are stored in the right place. 

    The white page when you are trying to view the attachments seems to me the problem.
    White page is normally an php error. Your php version is old and buggy.

    Maybe this is the reason for the problem. You should also see an php error in your webserver error log.
  • Thank you mfelber!! I solved it and now it works!!! Problem was in file.php. It has 0kb (I don't know why). I tried rewrite this file by file.php from new version of OsTicket and now it is great works. 

    Thank you so much! 
  • Glad to hear that. You're welcome.
This discussion has been closed.