Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion

osTicket v1.10 (stable) and Maintenance Release v1.9.15 are now available! Go get it now

[resolved] SMTP error "code -1" Connection refused

Hello,

I am running osTicket v1.8.1, Apache, PHP 5.5.27, MySQL 5.5.42, Web host is on CentOs (Hostgator), email is on external mail server, which is firewalled by mxlogic. IMAP settings function correctly and the system now fetches email using CRON. However, my SMTP settings receive the below error:

Failed to connect to webmail.domain.com:25 [SMTP: Failed to connect socket: Connection refused (code: -1, response: )]

I attempted to troubleshoot this issue with my email host for over 2 hours, allowing traffic to ports 25, 465, and 587, which did not yield any results.  I have not disabled SeLinux (don't know how to do this - cannot find it in my File Manager). Does any1 have ideas?

Thanks,

Tim

Comments

  • To disable SELinux on Centos do the following
    1. Check status of SELINUX:
    sestatus
    2. Disable it:
    vi /etc/sysconfig/selinux
    SELINUX=disabled
    reboot
  • Also osTicket v1.8.1 is really old... you should probably upgrade.
  • I think for changes to take effect on SELinux, you need to reboot the server first. image
  • That would be the last command that he listed.
  • I've determined that it is simply something with our (external) email host preventing this from working correctly.

    We now created a new email host dedicated to the inquiry system, which route our emails through this new domain. The problem is solved.

  • tdefreest, thank you for letting us know of this. I will close this thread.
This discussion has been closed.