Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion

osTicket v1.10 (stable) and Maintenance Release v1.9.15 are now available! Go get it now

class.plugin.php on line 673 error

I have a PC with Win 7, PHP6, MySQL 6.04, Apache 2.2.8 and I tried to install osTicket 1.9.12 and go to localhost, it gives me the following problem "Parse error: syntax error, unexpected T_FUNCTION, expecting ')' in C:\AppServ\www\soporte\include\class.plugin.php on line 673"
Can you help me?
Thanks

Comments

  • The only times that I have ever seen the T_Function error is when either:
    • PHP is not 5.4+
    • Someone manually edited the source code incorrectly.

    Please confirm the version of PHP that you are using.  You can do this by creating a file called test.php with a contents of <?php phpinfo(); ?> into your web tree and browsing to the file with your webbrowser.

  • Thanks ntozier, and I did the test and tells me that the php version is: 
    PHP Logo

    PHP Version 6.0.0-dev

  • Downgrade to PHP5. (5.4, 5.5, or 5.6)

    Note the lack of PHP6 releases.

    Here's why:
  • Ok ntozier, I used the php5.6 and the osticket is working.

    Thanks.
Sign In or Register to comment.