Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion

osTicket v1.10 (stable) and Maintenance Release v1.9.15 are now available! Go get it now

Software Versions Compatibility (LAMP

I am a newbie in osTicket system.  We want to install it ourselves.

From FAQ section, I found that there are the following software requirements:

osTicket is a platform-independent web-based application, meaning it is compatible with all operating systems. To install and run osTicket (as of version 1.8.0) the following components
are required;

     - Web Server: Apache or IIS
     - PHP Version: 5.3+
     - MySQL Database: 5.0+

May someone recommend workable combination of software versions for the above components?

My proposed combinations are:
- RedHat Enterprise Linux 6.6
- Apache 2.4.18
- PHP 7.0.3
- MySQL 5.7.11 (Community bundle version) for RedHat Enterprise 6

In addition, do you have any recommended document for building a LAMP (Linux, Apache, MySQL, PHP) server for osTicket?  I found one like, http://lamphowto.com/

Does it work?

Thank you for your help.

Comments

  • Sorry, I missed the osTicket version:

    My proposed combinations are:
    - RedHat Enterprise Linux 6.6
    - Apache 2.4.18
    - PHP 7.0.3
    - MySQL 5.7.11 (Community bundle version) for RedHat Enterprise 6
    - osTicket 1.9.12

  • edited March 2016
    You can use all of those except PHP 7.  osTicket does not support PHP7 at this time.   This will be changing in a future release.  You should use PHP 5.5 or 5.6.
  • Yes, thank you.

    I tried to install all components in rpm packages and I could start the osTicket installation webpage.

    I will press the button 'Continue' and see whether I can install it successfully.

  • Bingo.  It works!
Sign In or Register to comment.