Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion

osTicket v1.10 (stable) and Maintenance Release v1.9.15 are now available! Go get it now

[resolved] Can't connect to mail.xxxxx.xxx.xx,143: Permission denied

We are using Lotus Notes as our mail server.  I tried to setup an email account in osTicket system.

After I filled in the following information...

Email Login Information section
   Username: abc
   Password: abc
   ...
Fetching Email via IMAP or POP section
   Status: Enable
   Hostname: xxxx.xxxxx.xxx.xx
   Port Number: 143
   Mail box protocol: IMAP
   Fetched Emails: Move to folder: /var/mail/xxxxxx

I pressed the 'Submit' button but it failed to connect to IMAP.

At the top of the screen, it showed "Invalid login.  Check IMAP settings"

In IMAP section, it showed "Can't connect to mail.xxxxx.xxx.xx,143: Permission denied"

When I tested with telnet command, I could login IMAP successfully:

# telnet  mail.xxxxx.xxx.xx 143
Trying 172.5.2.1...
Connected to mail.xxxxx.xxx.xx.
Escape character is '^]'.
* OK Domino IMAP4 Server Release 8.5.3FP6HF1215 ready Tue, 12 Apr 2016 11:34:31 +0800
AUTH LOGIN abc abc
AUTH OK LOGIN completed

AUTH LOGOUT
* BYE logging out
AUTH OK LOGOUT completed
Connection closed by foreign host.
#

What things I miss for connecting to the IMAP?

Comments

  • My osTicket version is v1.9.12.  We are using RedHat Enterprise Linux, v6.6.
  • Fetching Email via IMAP or POP section
       Status: Enable
       Hostname: mail.xxxxx.xxx.xx
       Port Number: 143
       Mail box protocol: IMAP
       Fetched Emails: Move to folder: /var/mail/xxxxxx
  • Could be a SELinux issue..
  • What SELinux issue?  I am using RedHat.

    If it is linux issue, not Lotus Notes mail server's issue, why can I login the IMAP using telnet command?
  • I doubt that the login information formatted by osTicket has something wrong.  When the mail server received the login information, the mail server could not get the correct login id and password.  Is there any log files of osTicket that I can check for email issue?
  • The following command solves my problem:

    echo 0 >/selinux/enforce

    i.e. disable selinux
  • Thank you google.  I got that from google.
  • Permanently disabling selinux by:

    vi /etc/selinux/config

    #SELINUX=enforcing
    SELINUX=disabled


  • Thank you, mfelber
  • I would actually recommend that you read about SELinux and create a rule that allows the connection rather than disable it completely, but entirely up to you.   Since this is now resolved I am closing this thread and marking it resolved.
This discussion has been closed.