Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion

osTicket v1.10 (stable) and Maintenance Release v1.9.15 are now available! Go get it now

Opening an existing ticket as agent is slow (10s)

Hi there!
Just to share with you an issue we have since a few weeks.
The system is working great, here are our technical details:
  • CentOS 7.2.1511
  • Webmin 1.791
  • Apache 2.4.6
  • PHP 5.4.16
  • MySQL 5.5.47
  • <1 000 closed tickets
  • 3 users
It's a virtual machine with 2 CPU and 2GB of RAM

The issue we are facing is that the system is slow ONLY when opening an existing ticket AS AN AGENT.
The loading bar at the top goes fast but the page doesn't change.
Then the loading icon of Chrome is spinning
Then 9s later the ticket loads.

That's the only scenario the system is slow. When I open the same ticket as support user it's super fast (<1s).

I have tried to set up a clean install with zero ticket in db with the latest stable and the RC but the issue is the same.
Do you have a suggestion where I could look at?
I don't have any apache error except this kind:

[Wed Apr 13 09:32:59.484446 2016] [fcgid:warn] [pid 60124] (104)Connection reset by peer: [client 192.168.X.XXX:57014] mod_fcgid: ap_pass_brigade failed in handle_request_ipc function, referer: http://osticket.local/scp/tickets.php?status=answered

If you have any idea I would greatly appreciate it :)

Comments

  • You haven't included what version of osTicket you are running.

    When you say "ONLY when opening an existing ticket AS AN AGENT" you mean VIEWING an existing ticket?  Not OPENING?  right?

    Have you tried throwing more ram and processor power at it to see if that helps?




  • Hi!
    MY BAD. It's 1.9.12 (latest stable)

    Yes, I mean when VIEWING an existing ticket as an AGENT.
    And yes I have tried to increase the amount of Apache memory reserved to this site from 128MB to 1GB but no difference.
    Do you have a way I could diagnose this efficiently?
  • I think there are some issues with fcgi and virtualmin.
    Could you guys share me an example of a good-working php5.fcgi file?
  • Sorry I run IIS8.5.  Maybe someone else who runs Apache can help you.
  • So I'm the only one facing this kind of issue? Hmm...
    Thanks for trying though :)
  • I don't know if this could be a possible reason for this behavior but I'm recalling that someone has reported that the email verification can slow down some things. 

    Maybe you deactivate this setting to see if it has an impact on this issue:

    ->Admin Panel->Settings->E-Mail->uncheck "Verify email address domain"
  • OMG you are a life saver!! Now this loads in MILISECONDS.
    What the heck is wrong with that setting??
  • It tries to verify DNS for the domain... which can be... slow, or time out.  And it waits for a reply before it proceeds.
  • @notzier Do you know why the email verification is triggered when an agent views a ticket?
    Maybe it is not necessary and it would be better to allow those requests only if it is appropriate.
    What do you think?


  • @mfelber
    Q: Do you know why the email verification is triggered when an agent views a ticket?
    A: I have no idea.  I'm not a dev. :)

    Q: What do you think?
    A: I thought that it only happened when creating a new ticket, sending emails.
  • I've seen couple of other people having the exact same issue and couldn't narrow it down to this option.
    I will try to spread the information, but that's weird it's causing so much trouble.
Sign In or Register to comment.