Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion

osTicket v1.10 (stable) and Maintenance Release v1.9.15 are now available! Go get it now

Google Apps Legacy Account: Failed to connect to ssl://smtp.gmail.com:587 [SMTP: Failed to connect..

Hello Friends,

I have googled too much and tried all the options what ever I can get over these Net-World.
I need to rectify the issue of setting up SMTP for my Google Apps Legacy Account [Free Version].
But I'm continuously getting the same fail error message and could not go further a step forward.
The error message is as below.:

Failed to connect to ssl://smtp.gmail.com:587 [SMTP: Failed to connect socket: Connection timed out (code: -1, response: )]

image
https://drive.google.com/open?id=0B1ZcGWDDDguDZDctalBwQlFXT28

osTicket Version - v1.9.14 (8b927a0)
Web Server Software - LiteSpeed
MySQL Version - 5.5.50
PHP Version - 5.5.37

I have done setting of
Less Secure Apps also in Google Security.
Enabled IMAP & POP.

Tagged:

Comments

  • Since you are using GMail I have to ask, did you log into your gmail account and enable IMAP or POP in your settings?

    More can be found here:
    http://osticket.com/wiki/Email_settings
  • Yes Mr. ntozier.

    I have replied it in the original post itself

    "I have done setting of
    Less Secure Apps also in Google Security.
    Enabled IMAP & POP."

    I have did all those things what ever is available over net.
    I'm googling and trying from almost 15-20 days. I'm not a developer. So I can't get into script level. That is the only thing I'm lack of.
  • Okay, well now that we have ruled out the basics, do you have any firewalls on the web host or in your network that might be blocking traffic to their servers?
  • My experience is that using "ssl://" in the smtp configuration of osticket is only working with port 465.
  • Mr. ntozier,
    I will talk to my hosting provider.

    Mr. mfelber,
    I have tried both, but was failure. Any how as Mr. ntozier said, let me check on firewalls.

    -Sathya Charana SM
    osTicket -- Admin Control Panel.png
    1011 x 1203 - 71K
  • I tried this just for fun with my google mail account and it seems that this isn't so simple as it sounds ;-)

    There are several possible reasons for this behavior.
    In my case using this link from google helped to make it work with port 465:

    The information from this google support site helped me to find this link:

    There are some other possible reasons described that also could be responsible for that behavior...
  • Dear Friend mfelber,

    I have tried this "DisplayUnlockCaptcha" several repeated times. There was no expected result or changes.
    I forgot to mention this in Original Post. Sorry. I was thinking what I have forgot? This was one major point.

    Surely, as you said it might help someone. But, as per my understanding, this is required for the people who have enabled "Double Authentication" (Two Step Authentication) in Google Security. Otherwise may be it is not required.

    There was one more; "Google App Specific Password" earlier. Now a days, it seems like Google removed that option, after introducing Second level Authentication Via SMS/Call or through Google Android "Authentication APP",.... It seems.

    I'm not getting done after passing all these, friend.
    I need solution. Someone who knows it better can definitely help me.

    -Regards,
    Sathya Charana SM
  • In my google account the two step authentication is disabled but I could not use the google smtp server in osticket till I used the DisplayUnlockCaptcha link.

    After using the link I was asked if I wish to grant access to my google account. I confirmed it and after that I was redirected to a page that reported that the access is granted.

    Did you use the link on the same machine where you tried to configure the smtp settings?

    I'm not an expert in this things, trial and error is my "method" ;-)
Sign In or Register to comment.